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. . components with bars, the bars grow and shrink when the data changes and the visualization is run. In point-based chart components the points grow to
full size when the visualization is run. · · Export to Word The Export to Word option allows you to export your visualizations to Microsoft Word. Visualizations
in Word are dynamic and interactive. Export Model The Export Model option lets you export a copy of the original Excel file imported into the visualization to

your machine. The Excel file can be exported from a visualization that was created on your machine or on another machine. To export the Excel file, on the
Data menu, click Export Model. · Export to BusinessObjects Enterprise The Export to BusinessObjects Enterprise option lets you export your SWF files to

BusinessObjects Enterprise.
This enables you to centralize Crystal Xcelsius User Guide 11 1 Getting to Know Crystal Xcelsius Importing an XLF file from Xcelsius 3.0/3.5 SWF files so

that users can access them remotely through InfoView. For more information about this feature, see Chapter 8: Crystal Xcelsius Designer Integration
Features. · Save to Enterprise You can now save XLF files directly to a managed BusinessObjects Enterprise or Crystal Reports Server.

For more information about this feature, see the Crystal Xcelsius 4.5: Installation and Integration Guide. Importing an XLF file from Xcelsius 3.0/3.5
Xcelsius supports the ability to import an Xcelsius visualization created with Xcelsius 3.

0/3.5. This import ability lets current 3.0 and 3.5 customers upgrade their existing visualizations to take advantage of the new features of Xcelsius. Backup
your current XLF, JPG and external SWF files before upgrading your visualization. To upgrade your existing visualizations, start Xcelsius and select

File->Open. Select the XLF that you would like to upgrade and click Open. Xcelsius will detect that the XLF is an older visualization and warn the user that it
is going to import the visualization into Xcelsius, and that this may result in certain features not functioning. Note: After you import and save your

visualization with the latest Xcelsius version, the visualization cannot be opened using Xcelsius 3.

0/3.5. Xcelsius minimizes the impact of migrating visualizations from Xcelsius 3.0/ 3.5 to this new version. However, it is possible that some of your
visualizations, or more specifically, some components, will look slightly different from the original 3.0/3.5 file. The following are some of the most frequently

encountered changes: · · · The size of some components is different. In most cases the size difference is a matter of a few pixels.
Some custom colors appear to be slightly different. This is due to art improvements and the introduction of skins. The Table component differs in size and

formatting. In the event of formatting differences in your components, bring up the Properties panel for the component and re-link the properties that are tied
to the spreadsheet. Xcelsius supports Dynamic Data Sources across all components.

This enhancement impacts visualizations that contain selectors and charts. Compare the new visualization to the Xcelsius 3.0/3.5 visualization to verify that it
is functioning correctly. 12 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the Xcelsius system 1 Understanding the Xcelsius

system How Xcelsius differs from traditional reporting applications Xcelsius complements all types of Portal initiatives, Business Intelligence programs,
Executive Dashboards, Balanced Scorecard projects, Marketing Reports, and day-to-day reporting and presentation requirements.

Xcelsius does this by letting users participate in the report creation process and analysis. How Xcelsius works Import an Excel file into Xcelsius, create the
visualization, and publish the visualization. 1. 2. 3. To create an Xcelsius visualization Import an Excel file that contains the information you want to publish.
Build the visualization. Compile and publish the visualization. Step 1: Import the Excel file The first step in creating a visualization is to import the Excel file
that contains the data to support your visualization. During this step, Xcelsius makes a copy of the Excel file and imports the spreadsheet, including formulas,

values, and cell formatting.

Once the Excel file is imported, a copy of it is embedded into Xcelsius. You can continue using the original Excel file, but if you delete or add rows, columns
or data, you need to re-import the Excel file. Crystal Xcelsius User Guide 13 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius system Step 2:
Build the visualization After the Excel file is imported, you can use Xcelsius to build the visualization. Xcelsius contains components--from backgrounds to
charts-- that can be selected and linked to one or more cells in the embedded spreadsheet. If you're creating a chart, for example, you can select the chart

component, click it, and select the range of chart data from the spreadsheet. This process is similar to the way a chart is created using Excel. Xcelsius lets you
create dynamic visualizations by pointing and clicking your mouse. You can combine two or more components and link them to the spreadsheet. For example,
you can define point-and-click radio buttons that combine with a chart to show different information on the chart when each radio button is clicked. Step 3:

Compile and publish the visualization The final step is to preview and export the visualization.
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 Previewing lets you test your visualization and see how it will look and behave when it is exported. Xcelsius offers a variety of ways to publish your
visualization. For more details on how to publish your visualization, see "Exporting Crystal Xcelsius Visualizations" on page 109. Xcelsius visualizations can
be published in the following formats: · · · · · · · Macromedia Flash SWF HTML Microsoft PowerPoint Slide Adobe PDF Microsoft Outlook Microsoft Word
BusinessObjects Enterprise How visualizations look Visualizations created with Xcelsius can have any type of standard or personalized look. Visualizations

are also fully compatible with Microsoft Power Point, HTML, and Portals.
14 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the Xcelsius system 1 Xcelsius visualizations conform to SWF file format.
SWF is the vector-based graphics format designed to run in the Flash Player. Because a SWF file is vector-based, its graphics are scalable and play back
smoothly on any screen size and across multiple platforms.Also, a vector-based file usually has a smaller file size than a bitmap animation. Visualizations

created with Xcelsius are dynamic.
What-if scenarios let users adjust conditions on the visualization and view the results. Interactive components let users alter the visualization conditions. The

following examples show visualizations created with Xcelsius. Example 1: What-if presentation using alerts This visualization shows the return-on-equity
(ROE) for a financial institution against its peer group performance. The alert colors are triggered, comparing the selected bank against the peer group
average. Crystal Xcelsius User Guide 15 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius system Example 2: What-if presentation using a

calculator The following visualization was created to calculate the monthly payment for a home loan. Users can adjust the input values by moving the sliders.
The calculator dynamically changes and displays the new values. 16 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the
Xcelsius system 1 Example 3: Historical data comparison presentation The following visualization is a dynamic financial statement report. It shows the

traditional Statements of Income.

When a user clicks on an account, the visualization shows the historical data organized by region or as a comparison against competitors. Crystal Xcelsius
User Guide 17 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius tools Understanding the Xcelsius tools Before you begin using Xcelsius, take a
moment to familiarize yourself with the interface by reading the following sections. Using the Object Browser With the Object Browser, you can select, hide,
cut, copy, paste, delete, bring forward, move back, group, ungroup and access Properties panels of components. . The Object Browser is opened by default
when you start an Xcelsius session. If you have closed the Object Browser, to re-open click Object Browser Window on the View menu. Right-click context
menu Display a context menu by right-clicking on any component in the browser. This is the same menu displayed by right-clicking on a component on the
canvas, unless the item is grouped, when the menu displays the common properties of the group. Selecting components To select a component on the Object
Browser click the component name or icon to select the component on the canvas. To select multiple components click a component name or icon to select it,

and then hold down the CTRL key while you click the other components, if they are not adjacent to one another.
If the components are adjacent hold down the SHIFT key. 18 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the Xcelsius tools
1 Combine methods by selecting a group of components first with SHIFT+click and then other separate components using CTRL+click. Always select using
SHIFT+click first; this won't work in the other order. Select all components by selecting any one component then pressing CTRL+A. Note: You cannot select

a component that is marked as hidden.
Hiding components To hide a component on the Object Browser select the check box next to the component name. To hide multiple components select any of
the check boxes of a multiple selection. To hide all components select any one component, then press CTRL+A to select all components, and check the box

next to any one component. Grouping components Selected objects in the Object Browser can be grouped in the following ways. · · Group selected
components by right-clicking on any of the selected components and clicking Group from the context menu.

Select several components in the Object Browser, then click Group on the toolbar. Once grouped, the components will appear in the browser in tree form with
a folder representing the whole group. Expand the group folder by clicking the + button or double-clicking the folder icon or the group label. Once the group
is expanded, access the Properties panel for a component within the group by either double-clicking the component or by right-clicking for the context menu.

In this way properties can be edited without ungrouping the components. Tip: To ungroup selected components, click Ungroup on the toolbar. Deleting
components Delete any selected components by pressing DELETE or selecting Delete from the right-click context menu. Deleting a component can be undone
pressing CTRL+Z or clicking Undo on the Edit menu. To delete components within a group you must ungroup them. Crystal Xcelsius User Guide 19 1 Getting

to Know Crystal Xcelsius Understanding the Xcelsius tools Opening properties panels Properties panels for components, either alone or in a group, are
opened with the same procedures: · · · · · Double-click the icon or label.

Select the component and press ALT+ENTER. Right-click the component and click Properties. Properties panels that can be opened for a group are opened
separately from the Properties panels of individual components within the group: Right-click the group label or icon and click Properties. Select the group

and press ALT+Enter. Note: Do not double-click a group to open its Properties panel; unlike individual components, double clicking on a group entry
expands or collapses that group within the tree. Once a Properties panel is opened for one component you can navigate to the Properties panel of another

component by clicking on the entry in the Object Browser. Renaming components Each component is assigned a default browsing name when placed on the
canvas. This is the name that appears in the title bar of the Properties panel and in the entry in the Object Browser. You can override these default names to

provide your own. Double-click slowly on the component name in the Object Browser, a fast double-click will open the Properties panel.
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 This will put the name in label-edit mode. Edit the name and then press ENTER or click on another component. Note: You cannot rename a component that is
marked as hidden. 20 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the Xcelsius tools 1 Using the Components Explorer The
Components Explorer shows the available components. The window contains two views: · A category view where the components are organized in groups in a

tree view according to their functionality.
In the category view you can select a specific category and open that folder to see those components that apply to your selection. Xcelsius provides categories
that are both frequently used in the market and unique to Xcelsius: · · · · · · · · · · Art & Backgrounds Charts Collaboration Maps Selectors Single-Value Text
Web Connectivity Other A list view where the components are organized alphabetically. In the list view you can select a component alphabetically by name.
Navigating through components in the Components Explorer You can navigate to a component within the Components Explorer using either the mouse or

keyboard. To navigate with the mouse, double click on the category and any subcategories until you can select the component.
Crystal Xcelsius User Guide 21 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius tools To navigate with the keyboard, click anywhere within

the category window to select it, and then type the first letter of the category you wish to open. To open a folder when it is selected, use the right arrow key; to
close a folder when it is selected, use the left arrow key. To navigate through subcategories type the first letter of the subcategory. You can also move up and

down the tree using the up and down arrows. Navigation using keys in the list view of the components operates in the same way, except that there are no
folders. Each time a component is selected, a preview of how that component looks on the canvas will appear in the preview window. Folder selection shows a
blank in the preview window. Using the Component Properties panel The Component Properties panel displays the specific functionality of each component.
After you place a component on the canvas area, you can access the Component Properties panel by double-clicking the selected component. In general, the

Component Properties panel has the same structure for all components, but the functionality described is specific to each individual component.

The Component Properties panel has the following tabs: · General Tab Describes the basic and minimum required functionality for the selected component.
Typically, it contains an area for the title and an area for the Data Source Link or the values that the component represents. See "Step 2: Select the data

sources" on page 34 for more information. 22 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the Xcelsius tools 1 · Behavior
Describes functions related to the way the component will work on the visualization. Typically, it contains an area for defining the Display Status, entry
effects, and functions related to limits and interactivity. See "Dynamic Visibility functionality" on page 74 for more information. · Alerts Contains all the

related functionality required when using alerts. On this tab, you can define the number of alert colors, the colors used, and the target or budget. See "Alerts"
on page 78 for more information. · Appearance Contains a series of functions, and in some cases sub-tabs, that let you modify the appearance and final look

of each component.
On this tab, you will find options like font size, title location, and colors. · Drill Down Contains a series of parameters for adding drill-down capability for
charts. For information on the Drill Down tab, see "Drill Down tab" on page 171. Note: This tab applies only to Chart components. Component Properties

for multiple selections By selecting multiple components on the canvas, you can simultaneously edit Component Properties for each component in your
selection.

To access Component Properties for multiple components select your components and double click the selection. You can also access the component
Properties by right clicking the selection and selecting Properties from the context menu. If the components are of the same type, you will be able to edit

Properties specific to that component. For example, if your current selection contains three Line Chart components, you will be able to access the Component
Properties specific to the Line Chart. Any change made to the properties will apply to each component in the selection.

Component Properties of components of mixed types or groups are limited to the Display Status parameters of the Behavior tab. When a number of
components are grouped, the Component Properties for individual components within that group may be edited by right-clicking on that sub-group

component in the Object Browser window see "Using the Object Browser" on page 18. Using the canvas The canvas area is the white work area where you
place components to create a visualization. Crystal Xcelsius User Guide 23 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius tools Placing

components on the canvas using drag and drop 1. 2. 3. To place a component on the canvas area using drag and drop On the Components Explorer click a
component. Holding down the left mouse button, drag the component onto the canvas. Release the mouse button. The component is dropped on the canvas at

the location of the mouse pointer.

4. Repeat this procedure for each component. Placing components on the canvas using point and click 1. 2. 3. To place a component on the canvas area using
point and click On the Components Explorer click a component. Click the canvas area. Repeat this procedure for each component. Fitting the canvas to
components After you complete your visualization, you may want to adjust its final size to eliminate any surrounding white area. To do this, use the Fit

Canvas to Components button on the tool bar.
Your visualization size will be adjusted to the optimal size according to the components you are using. In addition, you can use the plus and minus buttons on

the toolbar to shrink or grow the canvas in smaller increments. Fitting the canvas to the window To resize the canvas so that it fits in the window, click Fit
Canvas to Window on the toolbar. Changing the canvas size You can change the canvas size before you start creating a visualization by clicking Properties

on the File menu. The Document Properties dialog box appears.
You can modify the preset size to some standard sizes, or you can create your own size. The ideal size of your visualization depends on the quantity of

components that you plan to use.
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  24 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding the Xcelsius tools 1 If you are building a simple visualization such as a
Portlet that contains a chart and slider, the size can be around 640x840. Use the full size screen for dashboards or one-page visualizations that contain

several charts and selectors. In the description field, you can write a brief description of your visualization, the author, the date, and its intended
functionality.

This information will appear to all other designers when they use your XLF file (XLF is the extension to which Xcelsius saves its internal files) or when you
save your visualization as a template. Using the Import Model button Use the Import Model button on the tool bar to import the Excel file that contains the

data to support your visualization. If it is the first time you are importing an Excel file for the visualization, you must browse for and select the file in the
Import Model dialog box. If you have already imported an Excel file into the application, you have the option to either re-import it or select a new one. 1. 2. 3.

4. Importing a spreadsheet from Excel into Xcelsius Click the Import Model button. The Import Model dialog box appears.

Click the Browse button. The Open dialog box appears. Select your Excel file and click Open. You return to the Import Model dialog box. Click OK.
Importing an Excel file creates a mirror copy of your Excel file in the Xcelsius application. This mirror copy is independent of your original file. Therefore, if
you make changes to your Excel file that affect the Xcelsius visualization, you will have to re-import the Excel file. See "Updating data for a visualization" on
page 36 for more instructions. Using Font Options You can change the font used by components in a visualization by using Font Options on the File menu.

Crystal Xcelsius User Guide 25 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius tools Unicode Font Options Unicode Font Options provides
more options for customizing the font used in the visualization. The following options are available for displaying fonts in Xcelsius: · Embedded Fonts

Xcelsius uses embedded fonts by default. This option generates the characters from the TrueType Font you select, and embeds them into the SWF file. Because
the font is embedded in the SWF file, the font displays properly regardless of whether the user has the TrueType Font installed. However, this option also

increases the time required to load the visualization, and the file size.
Note: Asian character sets are not supported with Embedded Fonts due to the large number of characters they require. You must use NonEmbedded Fonts for
situations where you require Asian characters. · Non-Embedded Fonts This option is recommended when creating models that require the extended character
set as defined by Unicode. Non-Embedded Fonts uses the SWF player to directly render the TrueType Font you select. Non-Embedded Fonts also lets you use

different fonts for different components in the same visualization.
However, depending on the TrueType Fonts installed on the user's machine, the fonts in the visualization may not display properly. Note: Some components,
such as chart components, do not support Non-Embedded Fonts. 1. 2. To change the font for a visualization On the File menu, click Font. The Font Options
dialog box appears. Choose the font option that you want. · If you want to use one embedded font for all components in the visualization: a. On the Font list,

click the font that you want. b.

Click OK. · If you want to use a different font for each component in the visualization, or you want to use non-embedded fonts: a. Click Unicode Font Options.
b. In the Unicode Font Options dialog box, click Use NonEmbedded Fonts. 26 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Understanding
the Xcelsius tools 1 c. Click OK. You can now use the Font Settings on a component's Properties panel to change the font used for that component. Setting the

Maximum Rows With the Maximum Rows command on the Data menu, you can set the maximum number of rows that Xcelsius will allow as a valid data
source selection. If you set a large maximum number of rows, the time required to load a visualization will be affected.

If you try to specify more rows than the Maximum Rows setting for a data source, a warning message that says "Truncation occurred" will appear. Using the
Format menu The Format menu provides various options for formatting the appearance of the components in the visualization. Align With the Align options,

you can align the bounding boxes of components or groups of components relative to the first component in the selection. Align functions require the selection
of at least two components. The following Align options are available: · · · · · · Make Same Size Left Center Horizontal Right Top Center Vertical Bottom With

the Make Same Size options, you can make the selected components the same width, height, or size as another component.
Space Evenly With the Space Evenly options, you can distribute a selection of components either horizontally (Across) or vertically (Down) so that there are

even spaces between them. Crystal Xcelsius User Guide 27 1 Getting to Know Crystal Xcelsius Understanding the Xcelsius tools Center in Document With the
Center in Document options, you can center selected components on the canvas. Note: To use the Center in Document options, you must have more than one
component selected. The following options are available: · · · Vertical Horizontal Both Other commands on the Format menu The following commands are

also available on the Format menu: · · · · Bring to Front Brings component to the topmost layer. Send to Back Sends component to the bottom layer.
Bring Forward Brings component forward one layer. Send Back Sends component back one layer. Using the Grid Tool The Grid command on the View menu

provides a layout tool that can aid in positioning components on the canvas. The following options for customizing the grid are available: · · · · Show Grid
This option controls the visibility of the grid. Snap to Grid This option aligns the selected components to the grid lines. Vertical Spacing This option sets the

vertical spacing intervals for the grid in pixels. Horizontal Spacing This option sets the horizontal spacing intervals for the grid in pixels. 28 Crystal Xcelsius
User Guide Getting to Know Crystal Xcelsius Creating backup files in Xcelsius 1 Creating backup files in Xcelsius With the Options command on the Tools
menu, you can set how you want Xcelsius to create backup versions of the XLF file that you are working on: · · · If you do not want to create a backup XLF

file, make sure the options in the Save Options area are cleared.
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 If you want to create a backup XLF file, select Always Create a Backup Copy. If you want to create a backup XLF file at specific intervals, select Automatic
Backup Save Every, and then set the interval.

Previewing the visualization With Xcelsius, you can preview your final visualization as many times as you need. It lets you experiment with various
combinations of components, colors, and layouts to make sure your visualization meets your requirements. Use the Preview button to toggle between the

design view and preview. In Preview, you can interact with the visualization as you would when it is published. Viewing sample Xcelsius visualizations The
sample visualizations included with your deployment of Xcelsius show how some of the components work. 1. 2. 3. 4. To view sample Xcelsius visualizations

On the File menu, click Samples.
The Samples dialog box appears. In the Category box, click User Guide Samples. In the Items box, click the component that you want to view an example of. A

description of the component and a preview of the visualization are shown. To view a sample visualization, click OK.
Crystal Xcelsius User Guide 29 1 Getting to Know Crystal Xcelsius Dynamic and static data sources Dynamic and static data sources Components have two
levels of interactions relative to the spreadsheet: · Dynamic · Static Dynamic data sources The content of the cells can vary during a simulation process and
Xcelsius will update its content. Example You want to create a visualization containing a radio button and a chart, to show the progress of several Human

Resources Training Program courses. You need to use the same chart for each course, so that your visualization is simple and dynamic. It will look like this:
Using Dynamic Data Sources lets the chart data change with each selection you make on the radio button. The radio button inserts a row that contains the

data for each course on a range that is linked to the chart.
Since the chart contains the Dynamic Link on the Data Source, the chart content changes with each selection you make on the radio button. This is described

in more detail in "Using the Selector components" on page 48. 30 Crystal Xcelsius User Guide Getting to Know Crystal Xcelsius Using templates 1 Static
data sources The content of the cells won't vary during the simulation; therefore, Xcelsius won't update its content. Example The Human Resources chart

using the chart and radio button components while remaining dynamic in functionality can also have a static data source. The Display Status Key imported
value determines the visibility of the chart. The value can be set to display the chart when the visualization is run. The Display Status Key value is fixed so that

the chart will always display. For example, if you link the chart to a Display Status Key cell with a value of 0.25999 and manually change the value in the
Display Status Key box, when the visualization is run the chart will not be visible as the Display Status values do not match. Using templates Xcelsius offers a

set of templates you can use to create a new visualization.

You can use the existing Xcelsius templates, or you can create a visualization from scratch and save it as a template. For more information on creating and
using templates, see "Creating templates" on page 104. Global Styles Global Styles are a set of appearance parameters that let you change the default visuals
of new components. You can also apply Global Styles to existing visualizations to change their overall appearance. Style parameters are broken up into three
major categories: · · · Styles Text & Labels Buttons and Backgrounds. In the Styles category you will find Markers, Lines and Borders. All components can be

generally defined as being constructed of certain pieces, those pieces can be grouped in the above categories. These categories, when defined as a whole,
create the global style. These parameters consist of only color parameters and do not affect fonts, text formatting or alerts. Crystal Xcelsius User Guide 31 1

Getting to Know Crystal Xcelsius Global Styles Note: Global Styles are not transferred with Xcelsius authoring file, or XLF files.
Opening an XLF does not load the Global Style used in the XLF into the machine it is opened on. If the Global Style used by an XLF is unavailable, the style

will continue to be used by the existing components in the visualization, but it will not be able to be applied to new components. For more information see
"Using Global Styles" on page 105. 32 Crystal Xcelsius User Guide Crystal Xcelsius User Guide Creating and updating Crystal Xcelsius visualizations

chapter 2 Creating and updating Crystal Xcelsius visualizations Overview Overview This chapter introduces the process of creating and maintaining Xcelsius
visualizations. Creating a visualization 1.

2. 3. To create an Xcelsius visualization Import the Microsoft Excel file that contains the data to be used in the visualization. Link the Xcelsius components to
the spreadsheet. Preview the visualization and publish it.

Step 1: Import the Excel file The first step for creating an Xcelsius visualization is to import an existing Microsoft Excel file that contains the data you want to
use in your visualization. 1. Importing a spreadsheet from Excel into Xcelsius On the Data menu, click Import Model. The Import Model dialog box appears.
Tip: You can also access the Import Model dialog box by clicking the Import Model button on the tool bar. 2. 3. 4. Click the Browse button. The Open dialog

box appears.

Select your Excel file and click Open. You return to the Import Model dialog box. Click OK. Note: The Excel file is imported into the Xcelsius application as a
copy of your original file. You can continue making changes or modifications in your original file and then re-import the Excel file. See "Updating data for a
visualization" on page 36 for detailed steps. Step 2: Select the data sources The second step for creating an Xcelsius visualization is to select the data sources
linked to the components. With this step, you assign one or more cells from your imported Excel file to one or more Xcelsius components. 34 Crystal Xcelsius
User Guide Creating and updating Crystal Xcelsius visualizations Creating a visualization 2 Example You need to show Revenues by Store using a Column

Chart, and the Price per Unit using a Horizontal Slider. 1.
2. Selecting the data source for the components Place the components on the canvas. Double-click the column chart component to open the Properties panel.

For more information, see "Using the Component Properties panel" on page 22. 3.
4. 5. 6. 7. 8.

9. Click the Data Range cell selector button. Select the range of cells that contain the data for the column chart from the imported spreadsheet, and click OK.
Type or link the chart title and subtitle.
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 Type or link the axis names and category labels. Click the horizontal slider component to open the Properties panel. Click the Link to Cell cell selector
button. Select the Price Per Unit cell from the imported spreadsheet, and click OK. Step 3: Previewing and publishing the visualization The third step is to
preview and publish the visualization. You can see a preview of the live visualization, test the simulation result, make the required adjustments, and finally,

generate the SWF or Flash animation that contains the visualization.

Then the visualization is ready for publishing and distribution. You can use the Preview button on the tool bar to toggle between the design view and preview.
In preview, you can interact with the visualization as you would when it is published. Once you are satisfied with the results of the preview, the visualization is
ready to be published. You can publish your visualization using one of the following methods: · · · · · · · Export as Macromedia Flash (SWF) Export as HTML

Export to Microsoft PowerPoint Export as Adobe PDF Email Content Using Microsoft Outlook Export to Microsoft Word Export to BusinessObjects
Enterprise Crystal Xcelsius User Guide 35 2 Creating and updating Crystal Xcelsius visualizations Updating data for a visualization See "Exporting Crystal
Xcelsius Visualizations" on page 109 for more information. Updating data for a visualization The Export Settings command on the File menu lets you specify
how you want to update data. You can re-import the Excel file and replace the entire visualization, or you can create more customized and sustainable data
replacement methods. The following options for updating the data in your visualization are available: · · · Use Current Excel Data This option takes the data

as it exists in the currently imported visualization. This is the default option. Use Another Excel File This option lets you specify a different Excel file from
which to take data at export time.

Use Web Service This option allows the exported visualization to get data dynamically from an external XML data source. For more information, see "Using
the Use Web Service Option" on page 79. · Use Flash Variables This option allows the exported SWF file to be updated through the FlashVars property of the
Macromedia Flash Player. For more information, see "Using Flash Variables to update a visualization" on page 85 for more information. Re-importing the

Excel file When you are creating a visualization you may need to re-import the Excel file into Xcelsius.
This is normally because you have decided to add or modify the data in the spreadsheet. Since Xcelsius makes a copy of the original Excel file and imports the

copy, when you make changes to the original Excel file, you will have to re-import it. When re-importing the Excel file, be aware that if you inserted rows,
columns or data, the links that you previously created may be damaged. Xcelsius will keep the link as a static reference. For example, if originally you linked

a chart to the range A2:H2, and after that you modified the Excel file the chart range is now A3:H3, you will need to manually adjust the link after re-
importing the Excel file.

Xcelsius will continue using the range A2:H2 until you manually change the link. 36 Crystal Xcelsius User Guide Creating and updating Crystal Xcelsius
visualizations Updating data for a visualization 2 1. To re-import the Excel file On the View menu, click Import Model. Tip: You can also re-import the Excel
file by clicking the Import Model button on the tool bar. 2. 3. 4. Select the Excel file to be imported. Select the re-import method. For more information, see

the list following this procedure.

Click OK. The Import Model dialog box provides the following options for specifying how data in the re-imported spreadsheet interacts with the existing links
in the visualization: · Refresh Data Sources This action will import the selected spreadsheet. Use this option when the Excel file is the same or with small

changes and you need to keep all previous links. All previously established links to the spreadsheet will be saved. However, if since the last import you have
inserted, deleted or modified rows, column or data, it is possible that the links will be affected. Review the links before saving the visualization. · Clear Data
Sources This action will import the selected spreadsheet and all previously established links will be lost. Use this option when the Excel file is significantly
different and you need to delete all the links. · Refresh Spreadsheet Format This option is available only when Refresh Data Sources is selected. Use this

option when some spreadsheet formatting parameters have changed which you want updated.
· Refresh Live Office Use this option to manually refresh the spreadsheet against the latest Live Office data before you re-import the spreadsheet. Re-

importing with renamed sheets Re-importing a spreadsheet that has a sheet that has been renamed will cause all links and formulas to be lost. A warning
message will recommend two things: · · Use the same sheet name. Re-import using the Clear Data Sources option. Crystal Xcelsius User Guide 37 2 Creating

and updating Crystal Xcelsius visualizations Updating data for a visualization Using the Use Another Excel File option With the Use Another Excel File
option you can generate SWF files that use different data than the Excel file that the visualization currently uses.

Example In a visualization that uses the retail price to calculate the expected revenue, you want Xcelsius to update a single cell while maintaining the original
imported values in all other cells. 1. 2. 3. 4.

5. To replace data from another Excel spreadsheet On the Data menu, click Replace Data Selection. The Replace Data Selection dialog box appears. Click
Add. In the Range Name box, type "Retail Price". Click the Range Selection cell selector button. The imported spreadsheet and the Select a Range dialog box

appear. Select the Retail Price cell and click OK. Only the selected cells will be modified each time the Excel spreadsheet is re-imported. You return to the
Replace Data Selection dialog box.

6. 7. 8. 9. Click OK. On the File menu, click Export Settings. The Export Settings dialog box appears. Click Use Another Excel File. Click the Browse button
and navigate to the Excel file to be used as the new data source. The SWF file using the new data source is generated.

11. With your visualization on the canvas, on the Data menu, click Replace Data Selection. This function lets you select the cell(s) that you want Xcelsius to
modify each time the Excel file is re-imported. All other cells will remain the same. You have created a sustainable visualization.

The new SWF will take the latest Retail Price available from the Excel file.
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 When the Retail Price changes, all you have to do is to generate a new SWF file. All other cells not affected by the Retail Price will remain the same. 38
Crystal Xcelsius User Guide 10. On the File menu, point to Export, and click Macromedia Flash (SWF).

Creating and updating Crystal Xcelsius visualizations Updating data for a visualization 2 Using Excel 2003 with XML Maps with Xcelsius Xcelsius supports
the XML functionality that is new to Excel 2003. Excel 2003 supports the ability to embed XML documents and schemas into a spreadsheet. These files can be
imported into Xcelsius, and SWF files that retain the link to the XML source generated. Note: · These XML features are not available with the version of Excel
2003 that is included in the following Microsoft Office 2003 products: · · · · Microsoft Office Standard Edition 2003 Microsoft Office Small Business Edition

2003 Microsoft Office Student and Teacher Edition 2003 Users of these products can still import and export XML files from a previously mapped spreadsheet.
Data that has been mapped using the Excel 2003 mapping functionality can be manually refreshed by using a XML Map Refresh button in your visualization.

Building the visualization After the Excel 2003 file has been set up, the next step is to build your visualization and configure the XML Map Options. For
information on setting up the Excel 2003 file with an XML map, refer to the on-line help in Microsoft Excel. Example You want to create a visualization that
lists stock market quotes for several companies based on data in an XML file.After the data has been imported into your Excel file you can use Xcelsius to

build a visualization that retains the link to the XML data source. This means that changes to the XML file will be reflected in the exported SWF file.

This visualization will display share price information for several companies. The stock information is contained in an XML file that has been imported into
the Excel file and mapped to a range of cells. A Table component has been tied to the range of cells to visualize the data. To build an Xcelsius visualization
using an Excel spreadsheet with an XML map 1. Import the Excel 2003 file. For more information on how to import an Excel file into Xcelsius see "Step 1:

Import the Excel file" on page 34. Crystal Xcelsius User Guide 39 2 Creating and updating Crystal Xcelsius visualizations Updating data for a visualization
2. 3. 4. 5.

6. 7. Place a table component on the canvas. Double-click the table component to open the Properties panel. Click the Display Data cell selector button.
Select the range of data in the imported spreadsheet, and click OK. On the Data menu, click XML Map Option. The XML Maps dialog box appears. In the

Map Name box, select the XML maps to be included in the SWF file. The range of cells that make up the XML Map will be exported with the data that was in
the Excel cells when the Excel file was imported into Xcelsius.

8. In the URL box, type the URL for the source file. Tip: You can also click the URL cell selector button to select the URL from the imported spreadsheet. 9.
Set the value in the Refresh every n seconds box. The default value for this option is 0. When this option is set to 0 the SWF file will only query the URL when

the SWF file is first loaded. A value greater than 0 will query the URL when the SWF file loads and will continue to query the URL. 10. Export the
visualization.

For more information, see "Exporting Crystal Xcelsius Visualizations" on page 109. Once the visualization has been exported you can open the exported SWF
file in your web browser. Changes made to the XML file will be reflected in your SWF file. 40 Crystal Xcelsius User Guide Crystal Xcelsius User Guide Using
Crystal Xcelsius Components chapter 3 Using Crystal Xcelsius Components Overview Overview This chapter introduces the Crystal Xcelsius components and

their most relevant functionality. Using chart components Each type of chart functions in a particular way appropriate to different types of visualizations: ·
Bubble Chart A chart that lets you compare a group or series of items based on three different parameters. It has an X-axis and Y-axis to represent the item

location over the chart area, and a Z value to represent the item size. You could use this chart to represent the market composition with the X-axis
representing the ROI by industry type, the Y-axis representing the Cash Flow, and the Z-axis representing the Market Value. · Line Chart A single- or multi-

line chart ideal for showing tendency over a period of time. Use this chart in visualizations that emphasize a trend line, such as Stock Prices or Revenue
History. · Pie Chart A chart that represents the distribution or participation of each slice or item over a certain total that is represented on the overall pie

value.
The pie chart is appropriate for visualizations, such as Revenue Contribution by Product. The overall pie size represents the total revenues. Each slice

represents a different product. · XY Chart A chart that displays data requiring two magnitudes to complete the analysis. The XY chart shows each data point
as a result of the intersection of X values and Y values.

You can use the XY chart in visualizations that compare ROI on the X axis against Market Value on the Y axis for a group of companies. · Combination Chart
A combination column and line chart ideal for displaying a range of values and a trend line for those values. You can use the combination chart in

visualizations examining stocks. A line series will show the historical stock price over the year, and a column chart will show the volume of trading for that
stock. 42 Crystal Xcelsius User Guide Using Crystal Xcelsius Components Using chart components 3 · Bar Chart and Column Chart A single- or multi-bar

chart that shows and compares one or more items over a period of time or in a specific range of values.
You could use a column chart in visualizations that contain the quarterly headcount by region. · Stacked Column Chart and Stacked Bar Chart A chart that

compares several variables over a period of time. Stacked bars compare one or more variables by adding one variable on top of another. This chart compares
several variables over a period of time such as Marketing Cost, General Cost, Administrative Cost. Each one of the cost components is presented in a

different color and each portion represents a different variable. The total bar size represents the Total Cost. · Area Chart A standard chart with vertical and
horizontal axes. Each point along the horizontal axis represents a data point. The actual values for each data point are plotted against the vertical axis. For

each series, colored areas are created by connecting the plotted points and the horizontal axis.

Use this chart in visualizations that emphasize a trend line, such as Stock Prices or Revenue History.
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  · Radar Chart and Filled Radar Chart A chart with axes that radiate outwards from the center of the chart. These charts can have several axes. They are
useful for plotting multidimensional sets of data. In the filled radar chart, the shape created by connecting the points along each axis is filled in with color.
You could use the radar charts to compare aspects of stocks. One axis could display the price, another the volume, another the Price to Earnings ratio, and

others any other relevant data on. · Stacked Area Chart A standard chart with vertical and horizontal axes. Each point along the horizontal axis represents a
data point. The actual values for the data points are plotted against the vertical axis, with each series adding to the total value.

You could use the stacked area chart to compare the revenue for multiple products as well as the combined revenue of all the products and the contribution of
each product to that combined revenue. · OHLC Chart and Candlestick Chart The open-high-low-close and candlestick charts are primarily used to display

stock data. Each marker corresponds to the four values, which are represented as lines attached to the marker on the OHLC chart and as colors on the
candlestick chart. Open displays the opening price of the Crystal Xcelsius User Guide 43 3 Using Crystal Xcelsius Components Using chart components

stock. High displays the highest price the stock achieved on that day.
Low displays the lowest price the of the stock on that day. Close displays the closing price of the stock. How to create a chart Creating a chart in Xcelsius is
similar to creating a chart in Excel. The minimum requirement is to have a list of values in an adjacent range of cells. After this, you can enhance your chart

with some basic information such as Title, Subtitle, Axis Titles and Series Names.
Example To create an Xcelsius visualization that shows the Revenues per Store for a Car Dealer company, you will need an Excel file that contains an

adjacent range of cells with this information. 1. To create an Xcelsius visualization with a chart component Import the Excel spreadsheet into Xcelsius. For
information on importing spreadsheets into Xcelsius, see "Using the Import Model button" on page 25. 2. 3. 4. Place a column chart on the canvas. Double-

click the column chart component to open the Properties panel. Type the title of the chart in the Chart Title box.

Tip: You can also click the Chart Title cell selector button to select the chart title from the imported spreadsheet. 5. Type the subtitle of the chart in the Chart
Subtitle box. Tip: You can also click the Chart Subtitle cell selector button to select the chart subtitle from the imported spreadsheet. 6. Click the Data Range
cell selector button and select the range of values from the imported spreadsheet. The data range is the list of values to be presented on the chart component.

Select the full range of values you want to display on the chart component. 7. Type the axis name in the Category (X) Axis box.
Tip: You can also click the Category (X) Axis cell selector button to select the axis name from the imported spreadsheet. 8. Type the axis name in the Value
(Y) Axis box. Tip: You can also click the Value (Y) Axis cell selector button to select the axis name from the imported spreadsheet. 44 Crystal Xcelsius User

Guide Using Crystal Xcelsius Components Using chart components 3 Note: In some cases, you must create a multiple bar chart.
To do this, select the Series options and select one or more series. Each series represents one group of bars that are represented with the same color. Sample

visualization: Drill Down Chart functionality Xcelsius charts can behave as selectors. Including selector functionality in the charts lets you create
visualizations that have drill-down charting functionality. This example creates a visualization that displays a pie chart that contains yearly sales data for

several branches.
When the user clicks on a slice of pie for a given branch the visualization will display the monthly sales data for that branch on a column chart. Note: You can

find the spreadsheet, sample XLF file, and sample SWF file for this visualization in the following location: C:\Program Files\Business Objects\Crystal
Xcelsius Designer 4.5\samples\User Guide Samples To create an Xcelsius visualization with a chart with drill-down functionality 1. Import the Excel
spreadsheet into Xcelsius. For this example the spreadsheet should contain monthly sales data for different branches. For information on importing

spreadsheets into Xcelsius, see "Using the Import Model button" on page 25. 2. 3. 4. 5.

Place a pie chart component on the canvas. Place a column chart component on the canvas below the pie chart component. Double-click the pie chart
component to open the Properties panel. Click the Data Range cell selector button and select the data range from the imported spreadsheet. For this example,
select the cells that contain the sales totals for the individual branches. 6. 7. On the Drill Down tab, click Enable Drill- Down. The Drill Down options for the

pie chart component can now be configured. On the Insert Value list, click Rows.
This will let you insert a row of data for each item that is placed in the Destination pane. Crystal Xcelsius User Guide 45 3 Using Crystal Xcelsius

Components Using single value components 8. Click the Insert Value In cell selector button and select an empty row of cells from the imported spreadsheet.
Note: The cells must be empty or the drill down functionality will be compromised. 9.

Click the Source Data cell selector button and select the source data from the imported spreadsheet. For this example, the range of cells should contain the
monthly sales data for the branches. 10. Close the Properties panel for the pie chart component. 11.

Double-click the column chart component to open the Properties panel. 12. Click the Data Range cell selector button and select an empty row of cells from
the imported spreadsheet. For this example, the range of cells must be empty as it will have the data on the monthly sales of the branch selected on the pie

chart inserted into the row. 13. Click the Chart Title cell selector button and select an empty cell. For this example, the cell must be empty as the title for the
chart selected on the pie chart component will be inserted into this cell. 14. Close the Properties panel for the column chart component. 15.

Click the Preview button to view the interaction between the pie chart and the column chart components. As you click on slices of the Pie Chart, the column
chart will update to show the monthly sales data for the selected branch. Using single value components Single value components let you add user

interactivity to your visualizations. Single value means that the components are linked to a single cell in the spreadsheet. After that, the component lets you
modify or represent the value of that cell.
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