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It describes universes, what they contain, how they are created, and the role that universes have in your business environment.
The typical universe development cycle is described, with best design practices recommended. The demonstration databases and universes shipped with this
release are also described. Note: $INSTALLDIR variable in this guide In this guide the variable $INSTALLDIR is the install root path for the data access files
used by Designer and Web Intelligence. This is the Business Objects installation path with the operating system sub directory that contains the Designer
executable and the data access drivers. Under Windows$INSTALLDIR = \\.
..\Business Objects\BusinessObjects Enterprise 11.5\win32_x86. For example C:\Program Files\Business Objects\BusinessObjects Enterprise 11.
5\win32_x86. 8 Designer's Guide Introducing Designer Designer and universe fundamentals 1 Designer and universe fundamentals Business Objects
Designer is a software tool that allows you to create universes for Web Intelligence and Desktop Intelligence users. What is a universe? A universe is a file
that contains the following: · · Connection parameters for one or more database middleware. SQL structures called objects that map to actual SQL structures
in the database such as columns, tables, and database functions. Objects are grouped into classes. Objects and classes are both visible to Web Intelligence
users. A schema of the tables and joins used in the database. Objects are built from the database structures that you include in your schema. The schema is
only available to Designer users. It is not visible to Web Intelligence and Desktop Intelligence users.
· Web Intelligence users connect to a universe, and run queries against a database. They can do data analysis and create reports using the objects in a
universe, without seeing, or having to know anythinltiple connections with Designer, but only one connection can be defined for each universe. This database
connection is saved with the universe. Designer provides a graphical interface that allows you to select and view tables in a database. The database tables are
represented as table symbols in a schema diagram. You can use this interface to manipulate tables, create joins that link the tables, create alias tables,
contexts, and solve loops in your schema. Web Intelligence users do not see this schema. Designer provides an object explorer view. You use the explorer tree
to create objects that map to the columns and SQL structures that are represented in the schema view. Web Intelligence users manipulate these objects to run
queries against a database.
Designer allows you to distribute universes by importing and exporting universes to the Crystal Management System (CMS) repository. How do objects
generate SQL? Web Intelligence users create queries by dragging objects into the Query work area. The definition of each object infers a Select statement.
When a query is run, a Select statement and optional Where clause for all the objects is run against the target database. Designer's Guide 13 1 Introducing
Designer How do you use Designer to create universes? When a user chooses to include dimension and/or detail objects with a measure object in the Query
work area, a Group By clause containing the content of those dimension and detail objects is automatically added to the Select statement.
The tables that are included in the From clause and the Joins in the Where clause, are inferred from the table schema that you build in the Structure pane.
What types of database schema are supported? Designer can support most types of database schema, including all those shown below. You do not need to
redefine or optimize your database before using Designer. How are universes used? Universes are used by Web Intelligence users. The universes are stored in
the Crystal Management System (CMS) repository.
An end user connects to a universe from a web browser. The connection to the database is defined in the universe, so by connecting to the universe, the end
user automatically has access to the data. The access to data is in turn restricted by the objects that are available in the universe. These objects have been
created by you, the universe designer, based on the user needs profile for a defined user group. 14 Designer's Guide Introducing Designer How do you use
Designer to create universes? 1 Representing a targeted data need A universe can represent the data needs of any specific application, system, or group of
users. For example, a universe can contain objects that represent the data needs of the Marketing or Accounting departments in a company. A universe can
also represent the data needs of a section within a department or any set of organized procedures such as a payroll or inventory system. An example of the
types of classes that could be used in a human resources universe is shown below: Employee Information Attendance Information Vacation Days Accrued Sick
Days Taken Total Absences Department Information HUMAN RESOURCES UNIVERSE Examples of classes in the universe depicted above are Employee
Information, Attendance Information, and Department Information. Designer's Guide 15 1 Introducing Designer How do you use Designer to create
universes? Universes and the database schema The following example shows sections of a database schema that have been used to create three universes;
PERSONNEL, INVENTORY, and SALES. Each universe contains classes and objects.
Each object maps to a part of the database structure. The SALES universe contains a class called STATISTICS which contains two objects; Average Revenue
and Total Profit. CUSTOMER UNIT PRICE PRODUCT STATISTICS - Average Revenue - Total Profit EMPLOYEE ADDRESS SALARY BONUS STOCK Current Value - Out of Stock ITEM NUMBER SALES universe PERSONNEL universe INVENTORY universe Who uses universes? Web Intelligence users use
universes for reporting and analysis. The universe should provide them with classes and objects relevant to their business domain. 16 Designer's Guide
Introducing Designer Who is the universe designer? 1 Who is the universe designer? Universes are created by a universe designer using Designer. There is
no standard profile for a universe designer. Within a company, the person designated as the universe designer may be the database administrator, an
applications manager or developer, a project manager, or a report creator who has acquired enough technical skills to create universes for other users.
Universe design teams There can be more than one universe designer in a company. The number of universe designers depends on the company's data
requirements. For example, one universe designer could be appointed for each application, project, department or functional area.
Required skills and knowledge A universe designer should have the following skills and level of technical knowledge: Skill/Knowledge Ability to analyze user
needs Description Universes are created to meet a user need for data.
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The universe designer must have the skills to conduct user needs analyses to create classes and objects that are relevant to the user vocabulary, and to
develop universes that meet the needs of the user community. These needs include report creation and query results that are suitable for analysis Universe
designer needs to have a good working knowledge of the company's database management system (DBMS), how the databases are deployed, the logical
database structure, and the type of data stored in company databases A working knowledge of SQL is necessary Database knowledge Stuctured Query
Language (SQL) Designer's Guide 17 1 Introducing Designer Introducing the universe development process What are the tasks of the universe designer? The
universe designer is normally responsible for the following tasks: · · · · Conducting user needs analysis Designing and creating the universe Distributing the
universe Maintaining the universe Introducing the universe development process The following sections give an overview of how you manually create a
universe, and describe how universe creation fits into a typical universe development cycle. Universe design methodology The universe design methodology
described in this manual consists of one planning stage, and three implementation phases: · · · · Analysis of business problem and planning the universe
solution Designing a schema Building the universe Distributing the universe to users Each implementation phase is based on an assumption that you have
completed an initial planning phase. The planning phase can be done without using Designer, and is the decisive phase for the success or failure of your
universe.
A poorly planned universe that is not based on a study of user reporting needs will be difficult to design, implement, maintain, and will not be useful to your
target users. Each of these phases is described as follows: 18 Designer's Guide Introducing Designer Introducing the universe development process 1 Plan
the universe before you start using Designer Before starting the first phase, you should spend up to eighty percent of the time allotted for the universe creation
project, planning the universe. You should note the following points: · You must analyze the data analysis and reporting needs of the target audience for the
universe. The structures that you use to create the schema should be based on a clearly defined user need to access the data contained in those tables and
columns. You should have a clear idea of the objects that you need to create before you start using Designer.
Do not create objects by looking at the columns available in the database, but identify columns that match an object that you have already identified from
your user needs analysis. · Designing a schema You create a schema for the underlying database structure of your universe. This schema includes the tables
and columns of the target database and the joins by which they are linked. You may need to resolve join problems such as loops, chasm traps, and fan traps,
which may occur in the structure by using aliases or contexts. You test the integrity of the overall structure. In this guide, the designing a schema phase is
described in the chapters Creating a schema with tables and joins and Resolving join problems in a schema. Building the universe You create the objects that
infer Select statements based on the components of your schema. You organize these objects into classes. These are objects that you have identified from an
analysis of user reporting needs. You can create many types of objects to enhance user reporting capabilities, multidimensional analysis, and optimize query
performance.
You test the integrity of your universe structure. You should also perform tests by running reports in Web Intelligence. The building phase is described in the
chapter Building universes. Distributing the universe You can distribute your universes to users for testing, and eventually for production, by exporting them
to the Crystal Management System (CMS) repository. This phase is described in the chapter Managing universes. Designer's Guide 19 1 Introducing
Designer Introducing the universe development process Universe development cycle Universe development is a cyclic process which includes planning,
designing, building, distribution, and maintenance phases. You use Designer to design and build a universe, however, the usability of any universe is directly
related to how successfully the other phases in the development cycle interact with each other. This section presents an overview of a universe design
methodology that you can use to plan and implement a universe development project. The table below outlines the major phases in a typical universe
development cycle: Development phase Prepare Description · · · · · · · · · Identify the target data source and become familiar with its structure. Know what
data is contained within each table of each of the target databases.
Understand the joins. Identify the cardinality. Know what is possible. Identify the user population and how it is structured; for example is the user group
structured by department or by task. Identify what information the users need.
Identify what standard reports they require. Familiarize yourself with their business terminology so that you can name objects sensibly. Analyze Plan
Implement Identify a project strategy. For example, how many universes should be created and which ones should have the capacity to be linked and to what
level. · Build the universe using Designer.
This manual covers this part of the universe development cycle, the actual use of the design tool. · Test Test frequently during the build process for validity
and reliability of inferred SQL. Form a small group of Web Intelligence power users who have some knowledge of what information they expect to get from
the universe. Ask the users to perform thorough tests simulating live usage of the universe(s). 20 Designer's Guide Introducing Designer Designer example
materials 1 Development phase Deploy Description Distribute the universe by exporting universe to the Crystal Management System (CMS) repository, where
it can be accessed by end users. Update and maintain the universe as the data sources and user requirements change and grow. Evolve Note: Universe design
should always be driven primarily by user requirements and NOT the data source structure. Optimizing universe planning and implementation time The
analysis of user requirements and design are the most important stages in the process. Users must be heavily involved in the development process if the
universe is going to fulfil their needs both with the business language used to name objects and the data that can be accessed.
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Implementation will be very quick and easy if the first three stages are carried out properly.
You can spend up to 80% of the time allocated to the development of a universe on the first three stages: · · · Preparing Analyzing Planning If you have spent
the time in the laying the foundation for your universe, the other 20% of the time spent actually using Designer to build your universe will be much more
productive than if you have not spent the necessary time in planning and analysis. Designer example materials The following samples are shipped with
Designer: Demonstration databases Most of the examples in this guide are based on the Club database built with Microsoft Access 2000. This database is
used by the sales manager of the fictitious business, Island Resorts, to perform sales and marketing analysis. You can find the database file, Club.mdb, in the
Databases subfolder in the Business Objects installation path. Designer's Guide 21 1 Introducing Designer Designer example materials For more information
on the structure of this database, refer to the appendix at the back of this guide. The efashion database is also shipped with this release. This MS Access 2000
database tracks 211 products (663 product color variations), sold over 13 stores (12 US, 1 in Canada), over 3 years. The database contains: · · · A central
fact table with 89,000 rows of sales information on a weekly basis. A second fact table containing promotions.
Two aggregate tables, which were set up with aggregate navigation. Demonstration universes A complete demo universe called beach.unv is delivered in the
Universes subfolder of the Samples folder in the BusinessObjects installation path. It was built with the Club database described above. You can use this
universe to learn how to build specific objects and classes with Designer.
Designer also comes with the efashion universe built using the efashion database. 22 Designer's Guide Doing basic operations chapter 2 Doing basic
operations Overview Overview This chapter describes the basic operations you perform in Designer to create, modify, and update universes. The following
topics are covered: · · · · · · · · · · · · Starting Designer Importing a universe Opening a universe Exporting a universe Saving a universe Creating a universe
Setting universe parameters Using the Designer user interface Using Find and Replace Organizing the table display Selecting schema display options
Printing a universe Note: $INSTALLDIR variable in this guide In this guide the variable $INSTALLDIR is the install root path for the data access files used
by Designer and Web Intelligence. This is the Business Objects installation path with the operating system sub directory that contains the Designer executable
and the data access drivers. Under Windows$INSTALLDIR = \\.
..\Business Objects\BusinessObjects Enterprise 11.5\win32_x86. For example C:\Program Files\Business Objects\BusinessObjects Enterprise
11.5\win32_x86. Starting Designer Designer can only be used with a Central Management System (CMS) repository. You must log in to the repository before
starting Designer. If you are starting Designer for the first time and want to work on an existing universe, you need to open the universe directly first, save it
with a secure connection and export it to the repository. You then import the universe to make updates and export updated versions.
This ensures that the CMS and the local universe versions are synchronized. Once you start Designer you can open a universe in one of the following ways:
24 Designer's Guide Doing basic operations Starting Designer 2 · · · Create a new universe Import a universe from the CMS repository Open a universe
directly from the file system A universe is only available to Web Intelligence users when it is exported to the repository. Importing a universe, making
changes, then exporting the updated universe is the most common way of working with Designer. It ensures that the CMS (repository) version is synchronized
with the file version. Note: You can save a universe to the file system. You do this when you want to share the universe with other users who may not have a
connection rights to the target CMS. See the section "Saving a universe" on page 33 for more information. You start Designer from the task bar by clicking
the Designer icon in the group of installed Business Objects products for this release. You are prompted to log into the CMS before Designer starts. Starting
Designer To start Designer: 1.
Designer Click the Start button on the taskbar. Point to the Programs menu. Click the Designer program from the BusinessObjects command. The login box
for the CMS appears. 2.
3. Designer's Guide 25 2 Doing basic operations Starting Designer 4. Type the following information. This information is normally provided for you by the
BusinessObjects administrator. Login information Description System User Name Password Authentication Name of the CMS server.
Your repository user name. Your repository password. Your security level 5. Click the OK button. The Designer startup screen appears, and an empty
Designer session opens. The user name and CMS name appear in the title bar. User and CMS name Note: Depending on options set for Designer, the Quick
Start universe design wizard can start automatically when you start Designer.Click Cancel to close the wizard. For more information on disabling other
wizard options, see the section "Disactivating the Quick Design wizard" on page 27. If you want to use the Quick Design wizard, then you can refer to the
section "Using the Quick Design Wizard" on page 307 of the .
26 Designer's Guide Doing basic operations Starting Designer 2 Using the Quick Design Wizard appropriately When you start a Designer session for the first
time, a Quick Design wizard appears by default. You can use the wizard to quickly create a universe, or to familiarize yourself with Designer, however, it is
not an appropriate tool for creating a complete universe that responds to end user reporting requirements. It is recommended that you disable the Quick
Design wizard, and use it only as a means to familiarize yourself with Designer, and not use it to design universes. All the universe design, building, and
maintenance information and procedures in this manual assume that you have disabled the Quick Design wizard, except for the chapter "Using the Quick
Design Wizard" on page 307 which deals specifically with using the wizard. For information on disabling other Quick Design wizard options, see the section
"Disactivating the Quick Design wizard" on page 27. Disactivating the Quick Design wizard When you first start a Designer session, a Quick Design wizard
appears by default.
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You can prevent the wizard appearing automatically when you create a new universe as follows: To disactivate the Quick Design wizard: 1. 2. Select Tools >
Options. The Options dialog box opens to the General page.
Clear the Show Welcome Wizard check box. This check box is already cleared if you have cleared the Run this Wizard at Startup check box from the Startup
Wizard Welcome page. Clear the File/New Starts Quick Design Wizard check box. Click OK. 3.
4. Note: You can activate the Quick Design Wizard at any time by selecting the above check boxes from the General page of the Options dialog box. Using the
Quick Design wizard is covered in the section "Using the Quick Design Wizard" on page 307. Giving all users access to a universe You can make a universe
accessible to all Designer users in both workgroup and enterprise mode, by saving a universe in workgroup mode. The connection for the universe cannot be
a secured connection.
If you want to make a universe available to all users, you must save the universe with an unsecured connection. Designer's Guide 27 2 Doing basic operations
Importing a universe To make a universe accessible to all Designer users: 1. 2. Verify that the universe that you want to make available to all users does not
have a secured connection. Secured connections are required to export universe to the CMS. If a universe has a secured connection, select or create a new
shared connection. See the section "Defining and editing connections" on page 41 for more information. Select File > Save As. A File Save box appears. 4.
Select the Save For All Users check box. 3. Select Save for all users 5. Click OK. Importing a universe You can import one or more universes stored in a
universe folder in the repository. You can only import a universe that has already been exported to the repository. When you import a universe, the CMS
checks the universe version on the repository file system. If the version is identical, the universe is made available to Designer. If the universe version on the
repository file system is more recent than the CMS version, a message box appears asking if you want to replace the universe in the folder. If you answer Yes,
then the universe on the repository file system is replaced by the version in the CMS.
28 Designer's Guide Doing basic operations Importing a universe 2 Importing a universe from the repository 1. To import a universe from the repository
Select File > Import. The Import Universe dialog box appears. 2. Select a universe folder from the drop down list box.
Or Click the Browse button and select a universe using the folder browser. You want to import a universe from this folder. 3. If you want to lock the universe,
double-click the universe name. A locked universe appears with a padlock symbol.
To unlock a universe, double-click it again. 4. 5. 6. Click a universe name. This is the universe that you want to import. Verify the file path for the import
folder in the Import Folder box. The universe is imported to this folder. Click OK. Designer's Guide 29 2 Doing basic operations Opening a universe What is
the difference between opening and importing? You can open a universe directly from the file system.
When you save this universe, it is saved only to the file system, it is not updated in the CMS. Updates in this universe are not available to Web Intelligence
users. When you import a universe, the current version available in the repository is made available to Designer. When you have finished modifying the
universe, you export it to the repository. The CMS is updated with the latest changes. Opening a universe You open a universe using the menu commands or
by clicking the Open button. When you open a universe directly without importing, you are opening a version on the local file system, that may not correspond
to the latest version in the CMS. 1. To open a universe directly Select File > Open. A File Open box opens to the directory designated as the default universe
file store.
You can set this directory in the Save page of the Options dialog box (Tools > Options > Save). 2. 3. If necessary, browse to the directory that contains the
universe file (.UNV).
Select a universe file and click Open Or Double click the universe file. The Universe opens in the current Designer window. 30 Designer's Guide Doing basic
operations Exporting a universe 2 Exporting a universe You make a universe available to Web Intelligence users and other designers by exporting a universe
to the repository. When you export a universe the universe is: · · moved to the selected universe folder on the repository file system and created in the Central
Management System (CMS). Each time the universe is exported to the repository, the universe version in the CMS is updated.
This is the version that is available to Web Intelligence users. Note: Saving a universe is not the same as exporting a universe. Saving updates the universe on
the repository local file system, but not the CMS repository version of the universe. See the section "What is the difference between exporting and saving?" on
page 33 for more information. How are universes organized on the repository file system? The repository stores universes on the local file system and in the
CMS server. You work on the universe version on the local file system. The local file system is the server on which Designer is installed. Your universes are
saved by default in the universes folder in your user profile path as follows: \\Documents and Settings\<user>\Application Data\Business Objects\Business
Objects 11.5\universes\@<repository name>\universe folder\<universe>.unv The universes stored in the CMS server are used for version control.
When you export an updated universe to the repository, the updated universe is copied to the CMS server. Example: Universe folders on the repository file
system The following diagram shows the universe folders on the repository file system for a user designer1. The subfolders that store universes are created
under the universes folder. This is the default root folder for universes for a user. Designer's Guide 31 2 Doing basic operations Exporting a universe The
user designer1 has rights to the repository VITRE. All universe folders for designer1 are under the subfolder @VITRE.j Exporting a universe to the repository
1. 2. To export a universe to the repository Select File > Export. The Export Universe dialog box appears.
Select a universe folder from the folder drop down list box. Or Click the Browse button and select a universe folder in the folder browser. You want to export
the universe to this folder. 3. If you want to lock the universe, double-click the universe name.
A locked universe appears with a padlock symbol. To unlock a universe, double-click it again. 4. 5. 6.
Click a group in the Groups list box. This is the user group that uses the exported universe.
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Click a universe in the Universes list box. The Universes list box shows the names of the active universes. If you want to export other universes that are not
open, click the Add Universe button, and then use the browser to select the other universes. 32 Designer's Guide Doing basic operations Saving a universe 2
7. Click OK. What is the difference between exporting and saving? When you save a universe, you update the version in the repository file system. This does
not update the CMS version. When you export a universe, the update of the version in the repository file system is synchronized with the update of the universe
in the CMS.
If you save a universe and do not export the updated version, the CMS is not updated. The saved universe is not available to other users. Each universe in the
repository is assigned a system identifier. Refer to the section "Identifying a universe in the repository" on page 441 for more information in identifiers. You
can not export a universe if it has been locked in the repository by another designer. You can export only a universe defined with a secured connection. Saving
a universe You should regularly save your universes throughout a work session. When you save a universe, Designer stores it as a file with a .UNV extension
on the local file system. In Web Intelligence, a user identifies the universe by the universe name (long name).
When you save a universe, the changes are not saved to the CMS. You must export the universe to the CMS when you have completed updating a universe.
You can use the following maximum characters in the universe name (the long name) and .unv file name: Name type Universe name .unv name Maximum
number of characters 100 Operating system maximum Designer's Guide 33 2 Doing basic operations Saving a universe Universe file names as identifiers You
should not change the universe filename .
unv after reports have been created based on that universe. If you change the filename, any report built on the universe with the old name, will not point to the
universe once its name has been changed. Saving a universe The universe name can be different from the .unv name. When you use Save As to save the
universe under new name, the new universe is not associated in the CMS.
You must export the new universe to the CMS to create a version of the new universe. You can use the following methods to save a universe: To save a
universe Select File > Save from the menu bar Click the Save icon Press CTRL+S from the keyboard · · · Saving a universe definition as PDF You save the
universe information as an Adobe PDF file. You can save the same information that you can print out for a universe. This information includes: · · · General
information: parameters, linked universes, and the graphical table schema. Component lists: lists of components in the universe including objects, conditions,
hierarchies, tables, joins, and contexts. Component descriptions: descriptions for the objects, conditions, hierarchies, tables, joins, and contexts in the
universe. You can select what components that you want to appear in the PDF from the Print Options dialog box (Tools > Options > Print). These options are
described in the section "Setting print options" on page 98. To save universe information as a PDF file: 1. Select File > Save As 34 Designer's Guide Doing
basic operations Saving a universe 2 2.
Select portable Document Format (PDF) from the Save as type drop down list box. 3. Click Save. Setting default save options By default, Designer stores the
files that you save in the Universe subfolder in the Business Objects path. You can specify another default save folder as follows: 1. 2. 3. 4. 5. Select Tools >
Options.
The Options dialog box appears. Click the Save tab. The Save page appears. Type a file path in the Default Universe Folder text box. Or Browse to a folder
that contains .
unv files. If you want to specify an automatic save time, select the Save Automatically check box and select or type a time period number from the Minutes
value select box. Click OK. 6. Designer's Guide 35 2 Doing basic operations Closing a universe Closing a universe You can use the following methods to
close a universe.
To close a universe: · · · Select File Close from the menu bar Click the close window button at the top right corner of the universe window Press CTRL+W
from the keyboard. Creating a universe Before you can build a universe, you must firstly create a new universe file. When you create a new universe file, you
must define a connection parameter to allow the universe to access your database middleware. You can also define other parameters that determine how
Designer creates objects, links from the current universe to other universes, and query restrictions. You save the new universe as a .unv file. The new universe
contains no classes and objects. You create these during the universe development process by designing a table schema and then creating objects that map to
database structures. What are universe parameters? Universe parameters are definitions and restrictions that you define for a universe that identify a
universe and its database connections, specify the type of queries that can be run using the universe, and set the controls on the use of system resources. You
define universe parameters from the Universe Parameters dialog box (File > Parameters) when you create a universe.
The database connection is the only parameter that you must manually select or create when you create a new universe. 36 Designer's Guide Doing basic
operations Creating a universe 2 You can modify these parameters at any time.You can define the following universe parameters: Parameter Definition
Description Universe name, description, and connection parameters and information. These are the parameters that identify the universe. Refer to the section
"Identifying the universe" on page 40 for information on defining and modifying this parameter. Version and revision information, designer comments, and
universe statistics. Refer to the section "Viewing and entering summary information" on page 49 for information on defining and modifying this parameter.
Indicates the strategies used by the universe. A strategy is a script used to extract structural information from a database. Refer to the section "Selecting
strategies" on page 51 for information on defining and modifying this parameter.
Indicates the limitations set for the use of system resources. Refer to the section "Indicating resource controls" on page 56 for information on defining and
modifying this parameter. Indicates the types of queries that the end user is allowed to run from the Query pane. Refer to the section "Indicating SQL
restrictions" on page 59 for information on defining and modifying this parameter.
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Indicates the settings defined for linked universes.
Refer to the section "Indicating options for linked universes" on page 61 for information on defining and modifying this parameter. Summary information
Strategies Controls SQL Links Creating a new universe The following procedure describes how you can create a new universe from scratch by defining
universe parameters then saving the universe. The procedure provides an overview of all the pages available from the Parameters dialog box. For more
detailed information on each step you should refer to the respective section for the parameter in this chapter. Defining all the parameters at universe creation
may not be necessary.
You must select a connection, but you can accept the default values for other parameters, and then modify them as appropriate when necessary. Designer's
Guide 37 2 Doing basic operations Creating a universe Creating a new universe from scratch To create a new universe from scratch: 1. Select File > New.
The Universe parameters dialog box opens to the Definition page. See the section "Identifying the universe" on page 40 for information on this page. · · Or
Type a name and description for the universe. Select a connection from the Connection drop-down list box. Click the New button if you want to define a new
connection that is not listed in the drop-down list. See the section "Defining and editing connections" on page 41 for information on defining a new
connection. · 2.
Click the Summary tab. The Summary page appears. See the section "Viewing and entering summary information" on page 49 for information on this page. ·
3. Type universe information in the Comments box. Click the Strategies tab. The Strategies page appears. It displays the strategies available for your
connected data source. See the section "Selecting strategies" on page 51 for information on this page. · Select a strategy from each of the Objects, Joins, and
Tables dropdown list boxes.
Depending on the RDBMS for the connection, there can be more than one strategy available from each drop-down list box. 4. Click the Controls tab. The
Controls page appears. See the section "Indicating resource controls" on page 56 for information on this page.
· · 5. Select or clear check boxes in the Query Limits group box. Enter values for the check boxes that you select. Click the SQL tab. The SQL page appears.
See the "Indicating SQL restrictions" on page 59 for information on this page. · 6. Select or clear check boxes as appropriate. Click the Links tab, if you want
to link the new universe with an existing universe. 38 Designer's Guide Doing basic operations Setting universe parameters 2 The Links page appears. See the
section "Indicating options for linked universes" on page 61 for information on this page. · 7. Click the Add Link button to select a universe to link with the
new universe. Click the Parameters tab. The Parameters page appears.
It lists SQL parameters that can be set to optimize SQL generation. See the section "Setting SQL generation parameters" on page 61 for information on this
page. 8. 9. Click OK. The universe and structure panes open up in Designer Select File > Save. · · Type a name for the universe file. Click Save. Setting
universe parameters You can set universe parameters for the following purposes: · · · · · · · · Identifying the universe Defining and editing connections Viewing
and entering summary information Selecting strategies Indicating resource controls Indicating SQL restrictions Indicating options for linked universes Setting
SQL generation parameters Each type of parameter is contained on a page in the Parameters dialog box (File > Parameters).Each group of parameters is
described in its respective section below.
Designer's Guide 39 2 Doing basic operations Setting universe parameters Identifying the universe Each universe is identified by the following parameters:
Identifier File name (8 characters) Long name (35 characters) Description Unique numeric ID Used by File system, and Web Intelligence to reference the
universe. Web Intelligence users. Web Intelligence Web Intelligence users. CMS to identify universe. This number is assigned to the universe when it is first
exported to the CMS.
The name and description parameters are defined at universe creation from the Definition page of the Universe Parameters dialog box. You can modify the
universe identification parameters at any time. You also define the database connection from this page. For information on defining a new connection, you
can refer to the section "Defining and editing connections" on page 41. You can define the following identification parameters for a universe: Identification
parameter Name Description Universe name.
Identifies the universe to Web Intelligence users. The name characters supported by the registry are defined by the General Supervisor. Character support is
RDBMS dependent. Description of universe purpose and contents. Optional field. This description is viewable by Web Intelligence users, so information in
this field can provide useful information about the role of the universe. Named set of parameters that defines how Web Intelligence accesses data in a
database file. All available connections appear in the Connections drop-down list box. You can also create new connections. Description Connection
Modifying universe identification parameters To modify universe identification parameters: 1.
Select File > Parameters. Or 40 Designer's Guide Doing basic operations Setting universe parameters 2 Click the Universe Parameters button in the toolbar.
The Universe Parameters dialog box opens to the Definition page. 2. 3. 4. Type a name and a description. Select a connection from the Connection drop-down
list box. Click the Test button to verify that the connection is valid. If you receive a message informing you that the server is not responding, the connection is
not valid.
You can correct connection parameters by clicking the Edit button and editing connection properties. If the error persists, refer to the section of the RDBMS
documentation relating to error messages. 5. Click OK. Defining and editing connections A connection is a named set of parameters that defines how a
Business Objects application accesses data in a database file.
A connection links Web Intelligence to your middleware. You must have a connection to access data. You must select or create a connection when you create
a universe. You can modify, delete, or replace the connection at any time. Note: See the Data Access Guide for complete information on creating, modifying,
and optimizing connections You can create a new connection from the Definition page of the Universe Parameters dialog box (File > Parameters >
Definition).
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You create a new connection when there is not an existing connection appropriate to the current universe. You can also edit the properties for a connection
from the Definition page. You can view all connections available to a universe from the Connections list (Tools > Connections). You can delete, edit, and
create new connections from this page. A connection contains three elements: · · · Data Access driver Connection and login parameters Connection type Each
element is described in the following sections: Data Access driver A Data Access driver is the software layer that connects a universe to your middleware.
Designer's Guide 41 2 Doing basic operations Setting universe parameters Data Access drivers are shipped with Business Objects products. There is a Data
Access driver for each supported middleware. When you install Designer, your Data Access key determines which Data Access drivers are installed. When
you create a new connection, you select the appropriate Data Access driver for the RDBMS middleware that you use to connect to the target RDBMS.
Connection and login parameters You configure the Data Access driver by specifying the following connection and login parameters.
Parameter Type Name User name Password Description Type of connection, personal, shared, or secured. Identifying name for the connection. Your
database user name. This is normally assigned to you by the database administrator. Your database password. This is normally assigned to you by the
database administrator. Use Single Sign-On When selected, the user name and password used to when refreshing access the CMS are automatically used as
database reports at view time login parameters. See the BusinessObjects Enterprise Administrator's Guide for information on setting up Single Sign-On. Use
database credentials associated with BusinessObjects user account When selected the user is forced to enter a database user password associated with their
BusinessObjects account to refresh a report. This is set at the Central Management Console level.
Refer to BusinessObjects Enterprise Administrator's Guide for information on setting up this option. Data source/Service Data source or database name. If
you are using an ODBC driver the data source name identifies the target database. If you are using a native driver, the database name identifies the target
database. Connection type The type of connection determines who can use the connection to access data.
Designer automatically stores all the connections that you create during a work session. The next time you launch a session, these connections will be
available to you. 42 Designer's Guide Doing basic operations Setting universe parameters 2 You can create three types of connections with Designer: · · ·
Personal Shared Secured Each connection type is described as follows: Personal connections Restricts access to data to the universe creator and the
computer on which it was created. Connection parameters are stored in the PDAC.LSI file located in the LSI folder in the Business Objects 11.
5 folder in you user profile directory, for example: C:\Documents and Settings\<user name>\Application Data\Business Objects\Business Objects 11.5\lsi
These parameters are static and cannot be updated. Personal connections are unsecured in terms of Business Objects products security. You do not use
personal connections to distribute universes. You could use personal connections to access personal data on a local machine. Shared connections Allows
access to data for all users. These connections are unsecured in terms of Business Objects products security. Connection parameters are stored in the
SDAC.LSI file located in the LSI folder in the Business Objects 11.5 folder in you user profile directory, for example: C:\Documents and Settings\<user
name>\Application Data\Business Objects\Business Objects 11.
5\lsi Secured connections · · · · Centralizes and controls access to data. It is the safest type of connection, and should used be to protect access to sensitive
data. You can create secured connections with Designer. You must use secured connections if you want to distribute universes through the CMS. Secured
connections can be used and updated at any time. Designer's Guide 43 2 Doing basic operations Setting universe parameters Setting passwords with personal
and shared connections You can set a password on any universe that has a personal or shared connection type. Using passwords, you can protect the universe
from unauthorized users in an environment without a repository. Note: If you forget a password, you can not recover the universe file. You should keep a
backup file of universe passwords. There are two different options available for the password you can set: · · Protection Password causes a dialog box to
appear; it simply prompts the user to enter the password.
If the password is correct, the universe is opened. Write Reservation Password causes the following dialog box to appear: The user can then open the
universe in read only mode, or in read-write mode by entering the correct password. To set a password when using personal or shared connections: 1. 2.
Select Tools > Options The Options dialog box appears.
Click the Save tab. The Save page appears. 44 Designer's Guide Doing basic operations Setting universe parameters 2 3. 4. Type a pass word in the
Protection Password or the Write Reservation Password text boxes.
You can enter up to 40 alphanumeric characters. Click OK. Defining a new connection You can define a new connection using the New Connection wizard.
You access the wizard from: · Definition page of the Universe Parameters dialog box (File > Parameters> Definition). You normally define a new connection
when there is not an existing connection available for the data that the universe needs to access. Connections list (Tools > Connections). See the section
"Editing a connection" on page 48 for more information on using the Connections dialog box. · You can use the connection wizard to set advanced and
custom parameters for a connection. Refer to the Data Access Guide (Help > Data Access Guide) for complete information on creating, editing, and
optimizing connections. To define a new connection: 1.
Select File > Parameters. Or Click the Universe Parameters button in the toolbar. Parameters The Universe Parameters dialog box opens to the Definition
page. 2. Click the New button. Note: You can also create a new connection from the Connections dialog box. Select Tools > Connections and click the Add
button from the Connections list. The Welcome page of the Connection Wizard appears. 3. Click Next.
The Database Middleware page appears. It lists the database and middleware that correspond to your Data Access driver key. 4. 5. Expand the node for the
target database for the connection.
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The supported middleware for that database appear under the node. Expand the node for the target middleware for the connection. Designer's Guide 45 2
Doing basic operations Setting universe parameters The Data Access driver for the middleware appears. Oracle Client is the Data Access driver for the
Oracle middleware 6. Click a driver name and click Next.
The Login Parameters page appears. The login parameters are described in the section Connection and login parameters. Do the following on the Login
Parameters page: · · · 7. Select the connection type from the Type list box: Secured, Shared, or Personal. Type a name for the connection. Type your user
name and password. These are normally assigned by your database administrator. Click Next. The Test Connection page appears. It summarizes the
information for your connection and allows you to verify that the connection is valid.
8. Click the Test Data Source button. If the connection is valid a message box appears indicating that the connection is correct. If you receive an error
message, check to see that you entered all the parameters correctly. If the error persists, refer to the section of your RDBMS documentation relating to error
messages. 9. Click Next. 46 Designer's Guide Doing basic operations Setting universe parameters 2 10. The Advanced Parameter page appears. You can set
connection time, array fetch, and set locked resource options from this page.
Refer to the Data Access Guide for a full description of advanced options. You can access the Data access Guide by selecting Help > Data Access from
Designer. 11. You can accept the default advanced settings, or type and select advanced options. Click Next.
12. The Custom page appears. You can customize the settings for listed parameters. Refer to the Data Access Guide for a full description of Custom settings.
13.
Accept the default, or modify the listed settings. 14. Click Finish. If you created the connection from the Universe Parameters dialog box, the Universe
Parameters dialog box appears with the new connection listed in the Connection box. If you created the connection from the Connections dialog box, the
Connections appears. the new connection is now in the list. Click Finish to close the list. Viewing available connections You can view all available stored
connections in the Connections list. You can edit existing connections, and create new connections. To view available connections: 1.
Select Tools > Connections. Designer's Guide 47 2 Doing basic operations Setting universe parameters The Connections list appears. It displays all the
connections available to the current universe. 2. Click Cancel to close the dialog box. You can edit connections from the Connections dialog box. You can edit
a secured connection only if you are working in online mode. Personal and Shared connections can be modified in any mode. You cannot modify the name of
an existing connection. Editing a connection To edit a connection: 1.
2. 3. 4. 5. 6.
7. Select Tools > Connections. The Connections list appears. Click a connection name in the list of available connections. Click the Edit button.
The Login page for the connection appears. Type a new data source, or database name in the Data Source or Service box if required. Type modifications to
login parameters as required. Click Next. The Perform a Test page appears. Click the Test Data Source button to verify the modified connection. 48
Designer's Guide Doing basic operations Setting universe parameters 2 8. Click Next to move to the Advanced and Custom pages. You can modify parameters
as required. You can also accept the default or existing values.
Click Finish from the Custom page to apply the changes to the connection. 9. Deleting a connection You can delete connections from the Connections list. You
can delete a secured connection only if you are working in online mode. Personal and Shared connections can be deleted in any mode. To delete a
connection: 1. 2. 3. 4. Select Tools > Connections.
The Connections list appears. Select a connection name in the list. Click the Remove button. A confirmation box appears. Click Yes.
The connection is removed from the list. Adding a new connection You can add a new connection from the Connections page by selecting Select Tools >
Connections, clicking the Add button, and following the Define a new connection wizard. Full Instructions for following the connection wizard are in the
section Adding a new connection. Viewing and entering summary information The Summary page displays universe administration information. You can use
this information to help you keep track of the development of the active universe.
The Summary page displays the following information: Information Created Modified Revision Description Universe creation date and the name of the
creator. Date of last modification and the name of the modifier. Revision number which indicates the number of times the universe has been exported to the
CMS. Designer's Guide 49 2 Doing basic operations Setting universe parameters Information Comments Description Information about universe for yourself
or another designer. This information is only available in Designer. You should include information about the universe for users in the Description field on
the Identification page. List of the number of classes, objects, tables, aliases, joins, contexts, and hierarchies contained in the universe. Statistics Viewing and
modifying summary information To view and modify summary information: 1. Select File > Parameters. Or Click the Parameters tool.
The Universe parameters dialog box appears. 2. Click the Summary tab. The Summary page appears. 3. 4. Type a comment in the Comment text box. Click
OK. 50 Designer's Guide Doing basic operations Setting universe parameters 2 Selecting strategies A strategy is a script that automatically extracts
structural information from a database or flat file. Strategies have two principle roles: · · Automatic join and cardinality detection (Join strategies) Automatic
class, object, and join creation (Objects and Joins strategies) Strategies can be useful if you want to automate the detection and creation of structures in your
universe based on the SQL structures in the database.
Note: Strategies that automate the creation of universe structures are not necessarily an essential part of universe design and creation. They can be useful if
you are creating a universe quickly, allowing you to use metadata information that already exists in a database or database design tool. However, if you are
building a universe by creating objects and joins that are based on relationships that come directly from a user needs analysis, then you will probably not use
the automatic creation possibilities that strategies offer. In Designer you can specify two types of strategies: Strategy Built in strategy External strategy
Description Default strategy shipped with Designer.
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