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Integration for SAP Solutions User's Guide Introduction 1 1 Introduction About this guide About this guide BusinessObjects Integration for SAP Solutions
provides you, the SAP user, with the ability to extract the business intelligence contained within your SAP systems. BusinessObjects InfoView allows you to
share your reports over the Web, and SAP Authentication enables Single Sign On between your SAP system and BusinessObjects Enterprise. BusinessObjects
Integration for SAP Solutions consists of several main components: Crystal Reports is the report-design tool that allows you to report off your SAP data;
BusinessObjects Enterprise provides the framework for managing, scheduling, and distributing reports over the Web. This solution allows tools such as
Voyager, Web Intelligence, LiveOffice as well as Xcelsius to report of SAP. Please refer to SAP-specific chapters within the user's guides of these tools for
further details. Who should read this guide This guide is intended for SAP and BusinessObjects users who want to design and report of SAP data sources
using BusinessObjects tools.
8 BusinessObjects XI Integration for SAP Solutions User's Guide What's new in BusinessObjects XI integration for SAP Solutions 2 2 What's new in
BusinessObjects XI integration for SAP Solutions Extending platform and language support This section gives a high-level overview of the key new features
provided in BusinessObjects XI Integration for SAP Solutions. BusinessObjects XI Integration for SAP Solutions delivers the strongest business intelligence
solution for SAP customers, with new capabilities aimed at adding value to SAP products while lowering the total cost of ownership and providing an SAPfamiliar user experience, especially for end-user self-service in ad-hoc query, reporting, and analysis. Extending platform and language support
BusinessObjects XI Integration for SAP Solutions provides additional platform support for SAP integration. New platform Linux SUSE10 SP2 New web
application servers · · · · Tomcat 6 Weblogic 10.3 Webshpere7 SAP Web Application Server 7.
10 New web browsers · · Internet Explorer 8 Safari 3.2.1 New language packs · · Finnish Czech Other upgrades The SAP Unicode RFC library will now be
supported on Windows platforms. 10 BusinessObjects XI Integration for SAP Solutions User's Guide What's new in BusinessObjects XI integration for SAP
Solutions Mass distribution of personalized SAP Crystal and Web Intelligence reports 2 Mass distribution of personalized SAP Crystal and Web Intelligence
reports Report publishing capabilities in BusinessObjects XI provide the ability to broadcast personalized SAP Crystal and Web Intelligence reports to a
large user population based on SAP user role definitions. With these new capabilities there is no need to replicate SAP data access authorization settings in
BusinessObjects Enterprise.
For more information about Publications, see the BusinessObjects Enterprise XI Publishing Guide. BusinessObjects XI Integration for SAP Solutions User's
Guide 11 2 What's new in BusinessObjects XI integration for SAP Solutions Mass distribution of personalized SAP Crystal and Web Intelligence reports 12
BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW 3 3 Reporting with SAP BW Reporting off BW Queries Reporting off
BW Queries This section introduces you to Crystal Reports and the integrated features of the SAP Tools toolbar. It shows how to create and select queries for
reports and how to save reports to BW. It concludes with a tutorial that guides you through the creation of a report that is based on the SAP DemoCube.
Formatted reporting overview With the BW Query driver, you can design formatted Crystal reports that are based on the data that is stored in SAP Business
Information Warehouse (BW). You base these reports on queries that you create with SAP's Business Explorer (BEx) Query Designer. Once you have
designed your Crystal reports, you can save them to BW and, if required, target them for translation in order to make them available to users in multiple
languages. This section briefly shows how to start SAP's BEx Query Designer from within Crystal Reports, but focuses primarily on Crystal Reports and your
task of selecting BW queries as data sources for Crystal reports.
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This section concludes with a step-by-step tutorial that guides you through the creation of a sales report that displays data from the SAP DemoCube.
BusinessObjects Enterprise allows you to share Crystal reports over the Web so that all users can view your formatted content.
For details about publishing reports to BusinessObjects Enterprise, see Publishing and Viewing Reports on page 94. Your BW queries may contain SAP
variables that appear as parameters in BusinessObjects Enterprise and Crystal Reports. To accommodate these variables, BusinessObjects XI Integration for
SAP Solutions employs dynamic pick lists. A dynamic pick list provides you with a list of possible values to choose for a parameter (variable). Additionally,
the values that are displayed in a dynamic pick list correspond to your user rights--you see only pick list values that you have the rights to report off.
Commands and connection settings in Crystal Reports Crystal Reports includes several integrated tools that allow you to report off your BW data. You can
access many of these tools from two locations: click 14 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off
BW Queries 3 the appropriate button on the SAP Tools toolbar, or click the corresponding command on the SAP menu. This section describes the available
commands and shows how to change the related settings in Crystal Reports. Tip: To show/hide the SAP Tools toolbar in Crystal Reports, on the View menu,
click Toolbars. Select the SAP Tools check box, and click OK.
Commands without icons are available only on the SAP menu. Button Command Function Create a new report Create New Report from based on a query that
is a Query already defined in BW. Open a Crystal report that has already been saved in BW. Save the report that is currently open to BW. You have the option
to prepare the report for translation and publish it to BusinessObjects Enterprise.
Save the report to BW with a different description and/or in a different role. Open Report Save Report Save Report As BusinessObjects XI Integration for SAP
Solutions Unot displayed, click the Group or Server tab and provide the valid BW system information. Contact your administrator if you are unsure of the
entries that need to be made. The next "SAP Logon" dialog box prompts you for User Data. 3.
Type your usual SAP user credentials in the Client, User, Password, and Language fields. Then, click OK. The Query Designer appears. 4. On the Query
Designer's toolbar, click New Query. The "New Query: Select InfoProvider" dialog box displays the InfoAreas and InfoProviders that are available on your
system. 20 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 5. Select the InfoProvider on
which you want to base your query, then click OK. The Query Designer automatically displays the InfoProvider in Flat mode, a display mode, which is
recommended when designing Crystal reports using the BW Query driver. For details about Flat mode, see the SAP Library > Business Information
Warehouse > Business Explorer.
BusinessObjects XI Integration for SAP Solutions User's Guide 21 3 Reporting with SAP BW Reporting off BW Queries 6. Define your query by selecting
measures and characteristics from the Key Figure and Dimensions lists and dragging them to the Columns area. Note: For complete information about using
the Query Designer, see the SAP Library > Business Information Warehouse > Business Explorer > Query Design: BEx Query Designer. 7. Click Query
Properties. 8. Click the Extended tab and ensure that Allow External Access to this Query is selected. This option allows other programs, like Crystal Reports,
to access this query. Click Save Query. 10.
In the Save Query dialog box, click Roles and select the role where you want to save the query. 11. Type a Description and a Technical Name for the query,
then click Save. 9. 22 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 The Technical
Name must uniquely identify the query and must adhere to SAP naming conventions.
12. Click Quit and Use Query. Crystal Reports generates a report that uses your query as its data source. The report opens in the Design tab of Crystal
Reports. You can now add fields, titles, charts, and other objects to the report.
Selecting existing queries for reports If you or someone else in your organization has already defined one or more queries for reporting purposes within BW,
you can select those queries as data sources for new Crystal reports. Note: The Data Explorer also provides an SAP BW Query node, which can be used to
connect to and select a BW query for a report. Use Data Explorer when attempting to report on an InfoCube directly using the MDX driver. To select an
existing query for a report 1. On the SAP menu in Crystal Reports, click Create New Report from a Query. Tip: You can also click the corresponding button
on the toolbar. The "SAP Logon" dialog box appears. BusinessObjects XI Integration for SAP Solutions User's Guide 23 3 Reporting with SAP BW Reporting
off BW Queries 2. On the System tab, select your BW system, then click OK. Note: If your system is not displayed, click the Group or Server tab and provide
the valid BW system information.
Contact your administrator if you are unsure of the entries that need to be made. The next "SAP Logon" dialog box prompts you for User Data. 3. Type your
usual SAP user credentials in the Client, User, Password, and Language fields, then click OK. The "Select Query for your Crystal Report" dialog box displays
the queries that are available through your Favorites, Roles, and InfoAreas in BW. 24 BusinessObjects XI Integration for SAP Solutions User's Guide
Reporting with SAP BW Reporting off BW Queries 3 4. Select the query with the data that you want to report off, then click OK. Crystal Reports generates a
report that uses your query as its data source. The report opens in the Design tab of Crystal Reports. You can now add fields, titles, charts, and other objects
to the report.
Saving reports to BW After designing a report based on a query, you can save the report to a role in BW. At the same time, you can prepare the report for
translation or automatically publish it to BusinessObjects Enterprise. Before saving your report, check its title by clicking Summary Info on the File menu.
The title that appears here is displayed to users in BusinessObjects Enterprise. The technical name of the query is used as the default title, but you can replace
it with a descriptive title that is more meaningful to SAP users.
BusinessObjects XI Integration for SAP Solutions User's Guide 25 3 Reporting with SAP BW Reporting off BW Queries Tip: Use the Save As command on the
File menu to save the report to disk.
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To save a report to BW 1. On the SAP menu, click Save Report. Tip: You can also click the corresponding button on the toolbar. 2.
In the "Save a Crystal Report to BW" dialog box, select the role where you want to save the new Crystal report. 3. If you are using NetWeaver 7.0.2 or higher,
type a Technical Name for the report (maximum 25 characters long). 4. Type a Description for the report (optional if you entered a Technical Name). 5. Click
Save. Depending on your connection settings, the "Save to BW options" dialog box may appear.
6. Select from the available options: · Prepare this report for translation When you select this option, the strings in your report are extracted and made
available for translation within SAP. For details, see Designing reports for translation on page 90. · Automatically publish to Enterprise For more
information on publishing reports, see Publishing and Viewing Reports on page 94. 26 BusinessObjects XI Integration for SAP Solutions User's Guide
Reporting with SAP BW Reporting off BW Queries 3 If you are unable to publish your report to BusinessObjects Enterprise, you may need to consult with
your administrator about licensing. · Don't show this dialog again If you select this option now, you can modify your default settings later by clicking Settings
on the SAP menu. For details, see Commands and connection settings in Crystal Reports on page 14. 7. Click OK. Using your own reports as templates By
creating customized reports that serve as templates, you can speed up the process of designing and formatting the reports that you generate from BW queries.
You can, for instance, create reports that include customized titles, corporate logos, or contact details in the Report Header. As well, you can place copyright
information along with page numbers in the Page Footer. You can then select one of these reports as the default template, which "Crystal Reports" will use
whenever you generate reports from BW queries. To create a report to use as a template 1. Using Crystal Reports, create a blank report without specifying a
data source.
2. Add the elements that you want included in the template (text objects, graphics, hyperlinks, Special Fields, and so on). Note: · · · You may add objects to
only the Report Header, Page Header, Report Footer, and Page Footer sections; these are the sections that are merged into the final report. When adding
graphics to a template, you can insert them as pictures or as OLE objects (static, embedded, or linked). You can add Special Fields to your report template, as
long as the fields are in no way dependent upon your SAP data.
Predefined Special Fields are available from the Field Explorer in Crystal Reports. 3. When you have finished designing the template, save your work.
BusinessObjects XI Integration for SAP Solutions User's Guide 27 3 Reporting with SAP BW Reporting off BW Queries To specify a default template 1. On
the SAP menu in Crystal Reports, click Settings. Tip: You can also click the corresponding button on the toolbar. The "Settings" dialog box appears. 2. In the
Default template field, specify the report (.rpt file) that you want to use as a template for all new reports that you create from BW queries.
3. Click OK. Note: If you later rename, move, or delete your report template, Crystal Reports will prompt you with an error message when you attempt to
create a new report from a BW query. You must specify a new report template (or none at all) before you can create the new report. Building your first report
off the SAP DemoCube This tutorial provides an introduction to Crystal Reports as you design a sales report. You begin by creating a query, which is selected
as the report's data source. You then: 28 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3
· · · · · · Insert database fields. Group and sort data. Summarize data. Add a template.
Specify a title. Preview the report. How to create a new query 1. On the SAP menu in Crystal Reports, click Start BW Query Designer. Tip: You can also click
the corresponding button on the toolbar.
The "SAP Logon" dialog box appears. 2. On the System tab, select your BW system, then click OK. The next "SAP Logon" dialog box prompts you for User
Data. BusinessObjects XI Integration for SAP Solutions User's Guide 29 3 Reporting with SAP BW Reporting off BW Queries 3.
Type your usual SAP user credentials in the Client, User, Password, and Language fields. Then, click OK. The Query Designer appears. 4. On the Query
Designer's toolbar, click New Query. The "New Query: Select InfoProvider" dialog box displays the InfoAreas and InfoProviders that are available on your
system. 30 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 5. Select the SAP DemoCube
and click OK. Note: The location of the SAP DemoCube varies, so you may need to browse to find it. The Query Designer automatically displays the
InfoProvider in Tabular Display mode, which is required when designing Crystal reports.
For details about Tabular Display mode, see the SAP Library > Business Information Warehouse > Business Explorer. 6. Select the following characteristics
from the Dimensions list, and drag them to the Columns area: · Country · · · Sales employee Material Material group 7. Select the following measures from
the Key Figure list, and drag them to the Columns area: · Net value BusinessObjects XI Integration for SAP Solutions User's Guide 31 3 Reporting with SAP
BW Reporting off BW Queries · · Tax Amount in Doc. Costs (SAP Demo) The Columns area should now appear as follows: 8. Click Query Properties. 9. Click
the Extended tab and ensure that Allow External Access to this Query is selected. This option allows other programs, like Crystal Reports, to access this
query. Note: For complete information about using the Query Designer, see the SAP Library > Business Information Warehouse > Business Explorer >
Query Design: BEx Query Designer.
To save the query in BW 1. Click Save Query. 2. In the "Save Query" dialog box, click Roles and select the role where you want to save the query. 3.
Type a Description, such as My sample sales query 4. Type a Technical Name, such as SALES_DEMO_QUERY The Technical Name must uniquely identify
the query--that is, the name can appear only once across all InfoProviders in BW. The Technical Name can be up to 30 characters long and must begin with a
letter. 5. Click Save.
32 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 How to create a new report based on
the query This section guides you through the process of creating a new report based on the query you created in the last section, How to create a new query
on page 29.
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To create a new report based on the query 1. While still in the BW Query Designer, click Quit and Use Query. Crystal Reports generates a report that uses
your query as its data source. The report opens in the Design tab of Crystal Reports. You can now add fields, titles, charts, and other objects to the report.
Tip: To ensure that Crystal Reports displays technical names and/or descriptions for SAP tables and fields, click Options on the File menu. Click the
Database tab, and make your selection in the "Tables and Fields" area. 2. On the View menu, click Field Explorer.
BusinessObjects XI Integration for SAP Solutions User's Guide 33 3 Reporting with SAP BW Reporting off BW Queries The "Field Explorer" appears. You
can expand Database Fields and "My sample sales query" to see a list of Description fields available for your report. To select fields for the report 1. Drag
and drop the following fields from the Field Explorer to the Details section of the report: · Sales employee Text · · · Material Text Costs (SAP Demo) Net value
34 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 Tip: You can drag and drop fields on
the Design tab to reposition them. 2. In the Page Header area of the report, double-click Costs (SAP Demo), highlight the text, and type Costs in its place.
This changes the default column heading that is displayed in the report. How to group and sort data This section guides you through the process of grouping
and sorting data based on the report you created in the last section, How to create a new report based on the query on page 33. To group and sort the report's
data 1. On the Insert menu, click Group.
The "Insert Group" dialog box appears. BusinessObjects XI Integration for SAP Solutions User's Guide 35 3 Reporting with SAP BW Reporting off BW
Queries 2. Click the first list and select Country as the field by which you want the data grouped. 3. Click the second list and select in ascending order as the
sort direction.
4. Click OK. 5. On the Insert menu, click Group. 6.
Click the first list and select Material Text as the field you want the data grouped by. 7. Click the second list and select in original order as the sort direction.
8. Click OK. Your report should now appear like this: 36 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting
off BW Queries 3 When you view this report, the records are first grouped according to the values in the Country field. The resultant groups are then
displayed in the report in ascending alphabetical order. The records in each Country group are further divided into secondary groups based on the values in
the Material Text field. The resultant groups are displayed in their original order. How to summarize and preview data This section guides you through the
process of summarizing and previewing data based on the report you created in the last section, How to create a new report based on the query on page 33.
To select a template for your report 1. On the Report menu, click Template Expert. 2. In the Available Templates list, click High Contrast. 3. Click OK. To add
a title to your report 1. On the File menu, click Summary Info. The "Document Properties" dialog box appears with the Summary tab displayed. 2.
In the Title field, type the text you want to display as the title of the report, such as Sales grouped by country and material. 3. Click OK. The title is inserted
into the template's Page Header when you preview the report. To preview and save your report 1.
On the Report menu, click Refresh Report Data. Crystal Reports refreshes the report against the query in BW and displays your newly designed report in the
Preview tab. 2. On the SAP menu, click Save Report, and save the report to a role in BW. For details, see Saving reports to BW on page 25.
BusinessObjects XI Integration for SAP Solutions User's Guide 37 3 Reporting with SAP BW Reporting off BW Queries You may want to resize or reposition
report elements, or further modify the report's design. You can, for instance, select and drag the borders of columns and column headings in order to resize
them in the Preview tab; or, you can quickly display only a subset of the data by filtering the records with the Select Expert. The Crystal Reports Online Help
provides extensive conceptual and procedural information, tutorials, and examples to help you use Crystal Reports to its fullest potential. Access the help by
pressing F1 anywhere within Crystal Reports. Building a report off a BW hierarchy This tutorial demonstrates how to report off a BW query with a hierarchy
using Crystal Reports. You begin by creating a simple BW query with a hierarchy. You then complete these steps: · · · Create a new report and group the data
hierarchically. Insert a summary. Adjust object positioning dynamically. Note: This tutorial builds on the topics covered in Building your first report off the
SAP DemoCube on page 28, which provides more details on steps such as logging on to your SAP system, selecting the SAP DemoCube, and saving queries.
To design a simple BW query with a hierarchy 1. On the SAP menu in Crystal Reports, click Start BW Query Designer. Log on to your SAP system if
prompted. 2. On the Query Designer's toolbar, click New Query. 3. Select the SAP DemoCube and click OK. 4. On the Query Designer's toolbar, click Table
Display to toggle to the view of the Query Designer that shows the Free Characteristics and Rows areas as well as the Filter and Columns areas. 38
BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 5.
Select the following measures from the Key Figure list, and drag them to the Columns area: · Billed Quantity · Net Value 6. Select the Sold-to party
characteristic from the Dimensions list, and drag it to the Rows area. 7. In the Rows area, right-click Sold-to party, and click Properties. The Characteristic
Properties dialog box appears.
BusinessObjects XI Integration for SAP Solutions User's Guide 39 3 Reporting with SAP BW Reporting off BW Queries 8. Next to the Hierarchy Name field,
click the Values button. The "Select Hierarchy" dialog box appears. 40 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP
BW Reporting off BW Queries 3 9. In the Available Hierarchies list, select Countries Actual and click OK.
You are returned to the "Characteristic Properties" dialog box. 10. In the Hierarchy Properties list, click the Expand to Level check box and, in the Value
field, type 5 The Expand to Level property allows you to set a maximum number of levels for a hierarchy in Crystal Reports. In this example, you set the
number of levels of hierarchy to 5.
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BusinessObjects XI Integration for SAP Solutions User's Guide 41 3 Reporting with SAP BW Reporting off BW Queries 11. Click Query Properties. 12. Click
the Extended tab and ensure that Allow External Access to this Query is selected. This option allows other programs, like Crystal Reports, to access this
query. 13.
Click OK and then save your query to the appropriate location. For this example, in the Description field, type Hierarchy - Simple Example, and in the
Technical Name field, type QRY_HIERARCHY_SIMPLE 14. Click Quit and Use Query. You now have a simple query with five possible levels of hierarchy.
You can display the query in either the Business Explorer Analyzer or as a dataset in Crystal Reports. To format the data, create a formatted Crystal report
42 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 using groups and summaries, as
described in Creating a report based on a BW hierarchy on page 43. Creating a report based on a BW hierarchy Crystal Reports 2008 has enhanced
hierarchical grouping capabilities. These enhancements allow you to easily create reports based on BW queries that contain hierarchies with variable levels.
Crystal Reports is able to determine each group's parent and children, and at the same time update hierarchical summaries. Crystal Reports gives you
increased layout control so that groups are now nested in a hierarchy, and you have more fine-grained control over hierarchy indenting.
You can indent specific objects in a section according to their hierarchy level, instead of automatically indenting all objects in the hierarchy. Some general
information about hierarchical reporting When you group data hierarchically, Crystal Reports sorts information based on the relationship between two fields.
A hierarchical relationship must be inherent in the data that you use for the report: · · · Parent and child fields must be of the same data type for the program
to recognize a relationship between them. The data in the parent field must be a subset of the data in the child field. For the top level of a hierarchy to appear
in a report, the value must appear in the child data, and the corresponding row in the parent data must be empty.
There cannot be any circular logic in the data (that is, A cannot be related to B, while B is related to C, and C is related back to A). · For example, if you want
to show the hierarchical relationship of the people who work in a department, you could group data by employee name (the child field) and specify the
hierarchy by using the field that lists whom the employee reports to (the parent field). In addition to a visual representation of the hierarchy inherent in your
data, a Crystal report that you have grouped hierarchically has several other characteristics: BusinessObjects XI Integration for SAP Solutions User's Guide
43 3 Reporting with SAP BW Reporting off BW Queries · · When you drill down on a group in the hierarchy, the drill-down view also shows the records that
are lower in the hierarchy. The report contains hierarchical group footers that include the records that are lower in the hierarchy of each group. You can
summarize data across the hierarchies.
Use the conditional-X-position feature to ensure that the indenting you set to show hierarchical relationships does not affect other fields in same section of
your report. Hierarchical levels are supported in the formula language through the use of the GroupingLevel and HierarchyLevel functions. · · Note: You
cannot use hierarchical summaries in formulas. Creating the report This section uses the query that you created in To design a simple BW query with a
hierarchy on page 38. This tutorial will use the following fields: · Hierarchy Name Node ID This field reflects the child values. · Hierarchy Name Parent ID
This field reflects the parent values. Combined with the Actual Node ID, Crystal Reports uses these fields to determine the hierarchy based on the information
received from the SAP BW query. · Hierarchy Name Canonical ID This field is the ID of the Node ID. · Hierarchy Name Node Description This field contains
the description of the Actual Node ID, or child values. To design a report based on a BW query with a hierarchy 1.
On the Insert menu click Group. 44 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries 3 2. In
the "Insert Group" dialog box, select the Actual Node ID to base the group on. This is the child field, that is, the field that you want to see the hierarchy of. 3.
Select in ascending order. By default, the group header of the report displays the value of the field you are grouping on. 4. Click the Options tab and select the
Customize Group Name Field check box. 5.
Click Choose From Existing Field and select Hierarchy Name Actual Node Description. BusinessObjects XI Integration for SAP Solutions User's Guide 45 3
Reporting with SAP BW Reporting off BW Queries 6. Click OK. 7. On the Report menu click Hierarchical Grouping Options.
8. Select Sort Data Hierarchically and on the Parent ID Field list click Hierarchy Name Actual Parent ID. Note: The Instance ID Field and Parent ID Field
must be of the same data type. For example, if the Instance ID Field holds string data, then the Parent ID Field must also hold string data. 9.
In the Group Indent field, enter the amount that you want each hierarchy level indented. 46 BusinessObjects XI Integration for SAP Solutions User's Guide
Reporting with SAP BW Reporting off BW Queries 3 Note: The value that you enter in the Group Indent field affects all other objects that are in the same area
as your hierarchical group. For example, if your report contains a salary field on the same line as the name of the employee, the salary field is also indented
when you use the employee field to create a hierarchical group. To indent only the hierarchy records and not the other objects, leave this value as 0 (zero)
and use the conditional-X-position feature. 10. Click OK. The report data is now displayed hierarchically. In this example the Details section has been hidden
to more clearly display the hierarchical relationship of the data. BusinessObjects XI Integration for SAP Solutions User's Guide 47 3 Reporting with SAP BW
Reporting off BW Queries Inserting a summary At this point you may want to insert a summary onto your report. You can now do this in the regular Crystal
Reports workflow.
To insert a summary 1. On the Insert menu click Summary. 2. On the Choose the field to summarize list, click the field that you want to insert the summary on.
In this example, it is the Billed Quantity field. 3. On the Calculate this summary list, click the summary operation you want. 4. On the Summary Location list,
click a location for the summary.
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In this example, it is the hierarchical group.
Note: You do not need to select Summarize across hierarchy in order to have the data summarized correctly in this example because Crystal Reports can
recognize the Hierarchy node summaries that the SAP BW data delivers. The report now displays the summary data across the hierarchy. Note: When you
drill down on a hierarchical group, the drill down page always includes groups lower in the hierarchy. 48 BusinessObjects XI Integration for SAP Solutions
User's Guide Reporting with SAP BW Reporting off BW Queries 3 The summary can be placed in the Group Header or Group Footer. The summary values
are indented.
To fix this see, Indenting a hierarchy without affecting other fields on page 49. Indenting a hierarchy without affecting other fields This procedure
demonstrates how to indent a hierarchy while keeping all other fields on a report in their original positions. It takes advantage of two new functions included
in Crystal Reports XI, HierarchyLevel and GroupingLevel. This procedure continues directly from the example outlined in Creating the report on page 44.
BusinessObjects XI Integration for SAP Solutions User's Guide 49 3 Reporting with SAP BW Reporting off BW Queries To indent a hierarchy without
affecting other fields 1.
On the Report menu, click Hierarchical Grouping Options. 2. Ensure that the Group Indent field is set to zero. 3. Click OK. The report now displays the data
without any indent. 4. Right-click the group header field and click Size and Position. 5. Click the Conditional Formula button beside the X position value field.
6. In the Formula Workshop, enter the formula: HierarchyLevel (GroupingLevel({[Hierarchy Name] Actual Node ID})) * 250 Note: · · The field {[Hierarchy
Name] Actual Node ID} appears with its technical name into the formula. Positions are measured in twips; there are 1440 twips in an inch. The report now
displays the summary data in its original position and the group headers hierarchically. 50 BusinessObjects XI Integration for SAP Solutions User's Guide
Reporting with SAP BW Reporting off BW Queries 3 New Functions Two functions new in Crystal Reports XI make this functionality possible. Report-Report
Interface overview Report-Report Interface (RRI) is a feature that allows you to create a relationship between a query in BW (referred to as the sender query)
and a Crystal report that is published to BusinessObjects Enterprise with a data source that is a different BW query (the receiver query). This relationship
allows users who view the sender query in BW to drill down on specific rows and go to an associated Crystal report that displays related data from the
receiver query. The sender and receiver queries can be any pair of BW queries, provided that the receiver query contains at least one BusinessObjects XI
Integration for SAP Solutions User's Guide 51 3 Reporting with SAP BW Reporting off BW Queries variable that is based on a characteristic from the result
set of the sender query. In this scenario, the associated Crystal report is refreshed on demand against the receiver query. Information about the user's request
is passed from the sender query, through the Crystal report (as a report parameter), and into the receiver query (as a variable).
This allows the Crystal report to display data that is filtered based on the context of the user's original request. To set up Report-Report Interface in BW 1.
Create a new query in BW. This will be the sender query that users will view from within BW. 2.
Create another new query in BW, and add at least one variable based on a characteristic that is included in the result set of the sender query. Note: For more
information on how to use variables, see Personalization in BusinessObjects Enterprise on page 147. This will be the receiver query. Users will view its data
in a Crystal report. Tip: You can use the SAP BW Variables Wizard to add the required variable to your query.
3. Design a Crystal report that is based on the receiver query. For details about creating a report based on a BW query, see Selecting existing queries for
reports on page 23. 4. Save the report to BW and publish it to BusinessObjects Enterprise. To associate the sender query with the Crystal report 1. In BW,
execute transaction rsbbs 2. Click the Query tab. 3. In the Sender field, type the technical name of the sender query, and then press Enter.
Tip: Press F4 to browse to the query. 4. Click Create. 5. In the Report Type list, select BW Crystal Report. 52 BusinessObjects XI Integration for SAP
Solutions User's Guide Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 3 6. Click the Look Up button in the Report area. 7.
Select the Crystal report that you want to associate with the sender query. Tip: Click the down arrow on the long bar under the Restrictions tab to filter the
list of reports.
8. Click Transfer (or F8 on your keyboard). 9. Click Save. 10.
Click the Back button (or F3 on your keyboard) repeatedly until you have backed out of the Maintain Sender/Receiver Assignment transaction (rsbbs). Note:
Backing out of this transaction is recommended to avoid complications with BW placing a lock on the query. Now, when users view the sender query in BW,
they can click a row, select Goto or the JUMP key, and select the related Crystal report to view. (If RRI is not set up for a characteristic in that row, no report
will appear as a Goto option.) Reporting off BW Queries and Cubes: MDX Query Driver This section introduces you to Crystal Reports and the integrated
features of the MDX Query Driver.
It shows how to format and build reports off a BW query and hierarchy. MDX Query driver overview The SAP BW MDX Query driver introduces new
flexibility when reporting off BW cubes and queries. By writing reports with the MDX Query driver, you gain direct access to BW cubes. You can also now use
display attributes, Multiple Structures, and Free Characteristics in your Crystal reports. BusinessObjects XI Integration for SAP Solutions User's Guide 53 3
Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver Additionally, the MDX Query driver provides the ability to create reports
from queries that contain hierarchy variables and hierarchy node variables. The driver creates specific fields that allow you to specify pick lists for your
variables in Crystal Reports. Formatted reporting overview With the BW MDX Query driver, you can design formatted Crystal reports that are based on the
data that is stored in SAP Business Information Warehouse (BW). You base these reports either on the queries that you create with SAP's Business Explorer
(BEx) Query Designer or directly on cubes. Once you have designed your Crystal reports, you can save them to BusinessObjects Enterprise and, if required,
target them for translation in order to make them available to users in multiple languages.
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This section focuses on Crystal Reports and the task of using the MDX Query driver to select BW queries and cubes as data sources for Crystal reports.
This section ends with a series of tutorials that guide you through the creation of reports off a sample query. Note: It is recommended that you complete the
tutorials in sequential order because each tutorial builds on the query and report you built in the previous tutorial. BusinessObjects Enterprise allows you to
share Crystal reports over the Web so that all users can view your formatted content. For details about publishing reports to BusinessObjects Enterprise, see
Publishing and Viewing Reports on page 94. Your BW queries may contain SAP variables that appear as parameters in BusinessObjects Enterprise and
Crystal Reports. To accommodate these variables in BusinessObjects Enterprise, BusinessObjects Integration for SAP Solutions employs dynamic pick lists. A
dynamic pick list provides you with a list of possible values to choose for a parameter (variable). Additionally, the values that are displayed in a dynamic pick
list correspond to your user rights--you see only the pick list values that you have the rights to as defined by SAP BW security settings. Note: In Crystal
Reports, the pick lists are static but in BusinessObjects Enterprise they are dynamic. 54 BusinessObjects XI Integration for SAP Solutions User's Guide
Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 3 Accessing BW queries for reporting This section outlines the ways in
which you can create BW queries and select existing BW queries to use as data sources for you Crystal reports.
To access the BEx Query Designer to create new queries, you can use the SAP Tools toolbar in Crystal Reports or you can use the Programs menu to
navigate to it. To select existing queries, you can use the SAP Tools toolbar in Crystal Reports or you can use the Database Explorer in Crystal Reports.
Creating new queries for Crystal Reports There are two ways you can access the BEx Query Designer to create a new BW query for Crystal Reports. You can
use the SAP Tools toolbar within Crystal Reports or you can use the Programs menu. For details about the SAP Tools toolbar, see Commands and connection
settings in Crystal Reports on page 14.
Note: The tutorials in this section use the SAP Tools toolbar to create new queries for reporting. However, when creating new queries you can use whichever
method you prefer. To create a BW query from the Crystal Reports SAP Tools toolbar 1. On the SAP menu in Crystal Reports, click Settings. Tip: You can
also click the corresponding button on the toolbar.
2. Select the Use MDX driver with support for Multiple structures check box and click OK. 3. On the SAP menu, click Start BW Query Designer. 4. When
prompted, log on to your SAP BW system. 5. On the Query Designer's toolbar, click New Query. The "New Query: Select InfoProvider" dialog box displays
the InfoAreas and InfoProviders that are available on your system. 6.
Select the InfoProvider on which you want to base your query, then click OK. BusinessObjects XI Integration for SAP Solutions User's Guide 55 3 Reporting
with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 7. Define your query by selecting measures and characteristics from the Key Figure
and Dimensions lists and dragging them to the Columns area. Note: When you create a new query for reporting purposes, it is recommended that you place
Key Figures in the Columns area of the Query Designer and Characteristics in the Rows area. 8. Click Query Properties. 9. Click the Extended tab and
ensure that Allow External Access to this Query is selected. This option allows other programs, like Crystal Reports, to access this query. 10.
Click Save Query. 11. In the "Save Query" dialog box, click Roles and select the role where you want to save the query. 12. Type a Description and a
Technical Name for the query, then click Save.
The Technical Name must uniquely identify the query--that is, the name can appear only once across all InfoProviders in BW. The Technical Name can be up
to 30 characters long and must begin with a letter. 13. Click Quit and Use Query. Crystal Reports generates a report that uses your query as its data source.
The report opens in the Design tab of Crystal Reports. You can now add fields, titles, charts, and other objects to the report. To create a BW query directly
from the BEx Query Designer 1. Go to Start > Programs > Business Explorer > Query Designer. 2. When prompted, log on to your SAP BW system. 3. On
the Query Designer's toolbar, click New Query. The "New Query: Select InfoProvider" dialog box displays the InfoAreas and InfoProviders that are available
on your system. 4.
Select the InfoProvider on which you want to base your query, then click OK. 56 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting
with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 3 5. Define your query by selecting measures and characteristics from the Key Figure
and Dimensions lists and dragging them to the Columns area. Note: When you create a new query for reporting purposes, it is recommended that you place
Key Figures in the Columns area of the Query Designer and Characteristics in the Rows area. 6. Click Query Properties. 7. Click the Extended tab and
ensure that Allow External Access to this Query is selected. This option allows other programs, like Crystal Reports, to access this query. Click Save Query.
9. In the "Save Query" dialog box, click Roles and select the role where you want to save the query. 10. Type a Description and a Technical Name for the
query, then click Save. The Technical Name must uniquely identify the query--that is, the name can appear only once across all InfoProviders in BW.
The Technical Name can be up to 30 characters long and must begin with a letter. 8. Selecting BW Queries for a report There are two ways you can access
BW queries to use as Crystal Reports data sources. You can use the SAP Tools toolbar in "Crystal Reports" or you can use the Database Explorer in Crystal
Reports. Using the SAP Tools toolbar to select an MDX query Note: · The tutorials in this section use the SAP Tools toolbar to create new queries for
reporting.
However, when creating new queries you can use whichever method you prefer. · Before you can see a query in the Database Explorer, you will need to set
the "Allow External access to the Query" option in its properties. 1. On the SAP menu click Create New Report from a Query. BusinessObjects XI Integration
for SAP Solutions User's Guide 57 3 Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver Tip: You can also click the
corresponding button on the toolbar. 2. When prompted, log on to your SAP BW system. The "Select Query for your Crystal Report" dialog box displays the
queries that are available through your Favorites, Roles, and InfoAreas in BW.
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3. Select the query with the data that you want to report off, then click OK.
Crystal Reports generates a report that uses your query as its data source. The report opens in the Design tab of "Crystal Reports". You can now add fields,
titles, charts, and other objects to the report. Using the Database Expert to select an MDX query 1. On the File menu in Crystal Reports, click New and then
click Blank Report. The Database Expert appears. 2. Under Available Data Sources, expand Create New Connection and then expand SAP BW MDX Query.
The "SAP System Logon" dialog box appears. 3.
Select the appropriate BW system and click Next. The next" SAP logon" dialog box prompts you for user credentials 4. Type your usual SAP user credentials
in the Client, Username, and Password fields, then click Next. Tip: To set the logon language, you must specify your Preferred Viewing Local in Crystal
Reports under View > Preferred Viewing Local. The next "SAP logon" dialog box asks you whether you would like to generate RFC trace files.
5. If you want the SAP Communication Library to create trace files for all client/server communication (for troubleshooting purposes), select the Generate
RFC trace files check box. 6. Click Finish. 58 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW
Queries and Cubes: MDX Query Driver 3 You are returned to the "Database Expert".
There are now two entries under your SAP BW MDX Query connection. One is labeled CU (Cubes) and the other is labeled (QC) Queries. 7. Expand QC
(Queries) to reveal the defined MDX BW Queries that are available as report data sources. Tip: If no items are found, check the Options setting of the Data
Explorer. a. Right-click QC (Queries) and click Options. This opens the "Options" dialog box with only the Database tab visible. b. In the Data Explorer area,
ensure that Stored Procedures is selected and then click OK.
You are returned to the Database Expert. c. Select SAP BW MDX Query and press the F5 key to refresh the Database Expert. BusinessObjects XI Integration
for SAP Solutions User's Guide 59 3 Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver d. Expand Current Connections and
then expand QC (Queries). Now there are lists of available queries. 8. Select the query that you want to report off and click the right-arrow button. 9. Click
OK.
"Crystal Reports" generates a blank report that uses your query as its data source. You can now add objects to the report. Showing field descriptions and
technical field names In Crystal Reports you can choose to identify fields by their description, name, or both. In some cases you may prefer to show both and
in other cases you may prefer to use just one. For example, when working with Multiple Structures, it is recommended that you show only the descriptions.
The Global Unique Identifiers (GUID) that SAP assigns to Multiple Structures are reflected in Crystal Reports and can be difficult to work with. To adjust the
field name and description settings 1. On the File menu, click Options. The "Options" dialog box appears, with the Layout tab active. 2.
Click the Database tab. 60 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries and Cubes:
MDX Query Driver 3 3. In the "Tables and Fields" area, select Show Name, Show Description, or Show Both. 4. Click OK. Tip: For more information about
formatted reporting, see the SAP Library > Business Information Warehouse > Business Explorer > Formatted Reporting: Crystal Reports Integration. Tips
regarding field names in Crystal Reports When you are viewing attribute names in Crystal Reports, the number that the attribute name is preceded by gives
you information about what kind of information the field contains. · 2 means that the attribute is the member key BusinessObjects XI Integration for SAP
Solutions User's Guide 61 3 Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver · 1, 4, or 5 means that the attribute is a
member description When you are viewing characteristic names in Crystal Reports, if the characteristic name is followed by many spaces and then the name
of a hierarchy, the characteristic contains that hierarchy. For example, if the Material characteristic contains the HIGHTECH hierarchy, it appears as
[0Material HIGHTECH]. The following fields are used for hierarchical grouping and parameter binding when there is a hierarchy node variable on a
characteristic.
These fields should not be used for reporting. · · · NodeId Parent NodeId MemberUniqueName Note: Putting the MemberUniqueName on a report will cause
performance issues. When a query contains a hierarchy variable, the MDX Query driver creates an extra field called Hierarchies in Crystal Reports that
allows you to create a list of values for the variable. The Hierarchies field has the following attributes: · · Hierarchy names Hierarchy descriptions This field
has no purpose other than to create lists of values for hierarchy variables. This field should not be used for reporting. Selecting cubes for reports If you or
someone else in your organization has defined one or more cubes for reporting purposes within BW, you can select them as data sources for new Crystal
Reports. To select an existing query for a report 1. On the File menu in Crystal Reports, click New and then click Blank Report. The "Database Expert"
appears. 62 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query
Driver 3 2.
Under "Available Data Sources", expand Create New Connection and then expand SAP BW MDX Query. The "SAP System Logon" dialog box appears. 3.
Select the appropriate BW system and click Next. The next "SAP logon" dialog box prompts you for user credentials 4.
Type your usual SAP user credentials in the Client, Username, and Password, fields, then click Next. Tip: To set the logon language, you must specify your
Preferred Viewing Local in Crystal Reports under View > Preferred Viewing Local. The next "SAP logon "dialog box asks you whether you would like to
generate RFC trace files. 5. If you want the SAP Communication Library to create trace files for all client/server communication (for troubleshooting
purposes), select the Generate RFC trace files check box.
6. Click Finish. You are returned to the "Database Expert". There are now two entries under your SAP BW MDX Query connection. One is labeled CU
(Cubes) and the other is labeled (QC) Queries. BusinessObjects XI Integration for SAP Solutions User's Guide 63 3 Reporting with SAP BW Reporting off BW
Queries and Cubes: MDX Query Driver 7.
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Expand CU (Cubes) to see the defined BW cubes that are available. Tip: If no items are found, check the Options setting of the Data Explorer. a. Right-click
CU (Cubes) and click Options.
b. This opens the "Options" dialog box with only the Database tab visible. c. In the "Data Explorer" area, ensure that Stored Procedures is selected and then
click OK. d. You are returned to the "Database Expert". e. Select SAP BW MDX Query and press the F5 key to refresh the Database Expert. f. Expand
Current Connections and then expand CU (Cubes).
g. Now there are lists of available cubes. 8. Select the cube that you want to report off and click the right-arrow button. 9.
Click OK. 64 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query
Driver 3 "Crystal Reports" generates a blank report that uses your cube as its data source. You can now add objects to the report. Multiple Structures and
Crystal Reports The MDX Query driver recognizes Multiple Structures and allows you to use them in your Crystal reports. Multiple Structures show in
Crystal Reports as a single dimension.
That is, they show with no attributes. The structure consists only of the members that are in the query. Saving reports to BW After designing a report based on
a query, you can save the report to a role in BW. At the same time, you can prepare the report for translation or automatically publish it to BusinessObjects
Enterprise. Before saving your report, check its title by clicking Summary Info on the File menu. The title that appears here is displayed to users in
BusinessObjects Enterprise. The technical name of the query is used as the default title, but you can replace it with a descriptive title that is more meaningful
to SAP users. Tip: Use the Save As command on the File menu to save the report to disk. To save a report to BW 1. On the SAP menu, click Save Report.
Tip: You can also click the corresponding button on the toolbar. 2. In the "Save a Crystal Report to BW" dialog box, select the role where you want to save
the new Crystal report. 3. If you are using NetWeaver 7.0.2 or higher, type a Technical Name for the report (maximum 25 characters long). 4. Type a
Description for the report (optional if you entered a Technical Name). 5.
Click Save. Depending on your connection settings, the "Save to BW options" dialog box may appear. BusinessObjects XI Integration for SAP Solutions
User's Guide 65 3 Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 6. Select from the available options: · Prepare this
report for translation When you select this option, the strings in your report are extracted and made available for translation within SAP. For details, see
Designing reports for translation on page 90.
· Automatically publish to Enterprise For more information on publishing reports, see Publishing and Viewing Reports on page 94. If you are unable to
publish your report to BusinessObjects Enterprise, you may need to consult with your administrator about licensing. · Don't show this dialog again If you
select this option now, you can modify your default settings later by clicking Settings on the SAP menu. For details, see Commands and connection settings in
Crystal Reports on page 14. 7.
Click OK. Building a report off a BW query This tutorial provides an introduction to reporting off a query using the BW MDX Query driver. You will perform
the following tasks in this tutorial: · · Create a query Select the query as a data source for a Crystal report 66 BusinessObjects XI Integration for SAP
Solutions User's Guide Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 3 · · · · Insert database fields Group and sort data
Summarize data Preview the report How to create a simple BW query This section guides you through the process of creating a query, saving it to BW, and
releasing it for use by Crystal Reports. Note: This tutorial uses the SAP Tools toolbar method to create a new BW Query. To create a simple BW query 1. On
the SAP menu in Crystal Reports, click Start BW Query Designer. Tip: You can also click the corresponding button on the toolbar. 2. When prompted, log on
to your SAP BW system. The "Query Designer" opens.
3. On the Query Designer's toolbar, click New Query. The "New Query: Select InfoProvider "dialog box displays the InfoAreas and InfoProviders that are
available on your system. 4. Select the Customer-Cube and click OK. Note: The location of the Customer-Cube varies, so you may need to browse to find it. 5.
Select the following characteristics from the Dimensions list, and drag them to the "Rows" area: · Division · Material Tip: You can find Division under the
Sales area data dimension. BusinessObjects XI Integration for SAP Solutions User's Guide 67 3 Reporting with SAP BW Reporting off BW Queries and
Cubes: MDX Query Driver 6. Select the following measures from the Key Figure list, and drag them to the Columns area: · Invoiced quantity · 7.
Sales Volume Click Query Properties. 8. Click the Extended tab and ensure that Allow External Access to this Query is selected. This option allows other
programs, like Crystal Reports, to access this query. To save the query in BW 1.
Click Save Query. 2. In the "Save Query" dialog box, click Roles and select the role where you want to save the query. 3. Type a Description, such as Sample
Material query 4.
Type a Technical Name, such as MATERIALSAMPLE01. The Technical Name must uniquely identify the query--that is, the name can appear only once across
all InfoProviders in BW. The Technical Name can be up to 30 characters long and must begin with a letter. 5. Click Save. To use the query in Crystal Reports
· Click Quit and Use Query. Crystal Reports generates a report that uses your query as its data source. The report opens in the Design tab of Crystal Reports.
You can now add fields, titles, charts, and other objects to the report. How to create a new report based on the query This section guides you through the
process of creating a new report based on the query you created in the last section, How to create a simple BW query on page 67.
68 BusinessObjects XI Integration for SAP Solutions User's Guide Reporting with SAP BW Reporting off BW Queries and Cubes: MDX Query Driver 3 To
create a new report · On the View menu, click Field Explorer. The "Field Explorer" appears. Expand Database Fields and Sample Material query to see the
list of fields available for your report. Tip: To change how the fields are identified in Crystal Reports, see Showing field descriptions and technical field
names on page 60. To select fields for the report 1. Expand Key Figures.
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